Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V15 - Secure Coding and Architecture Incorrect resource transfer between spheres
|
| Impact | The CVSS 3.1 score of 6.3 reflects a medium-severity vulnerability with low attack complexity (AC:L) and low privilege requirements (PR:L), but the impact is constrained to local attack vector (AV:L) and partial confidentiality/integrity/availability loss (C:L/I:L/A:L). However, real-world risk is elevated by several factors: (1) the PoC is publicly available via SBA Research, reducing exploitation friction; (2) the vulnerability affects authenticated users only, limiting the attack surface compared to unauthenticated RCE; (3) EUVD classification and OSS-Security mailing list disclosure indicate coordinated vulnerability disclosure was followed. The CVSS vector suggests this is not a critical system compromise, but in environments where RAG APIs handle sensitive data (medical records, proprietary documents), the confidentiality breach becomes more severe. SSVC analysis would classify this as low technical impact with moderate exploitability, warranting urgent patching for organizations handling sensitive data through LibreChat's RAG integration. |
| Exploit ScenarioDerived | An authenticated LibreChat user with local system access obtains their JWT token from the browser's local storage or application cache. The attacker submits this token to the RAG API endpoints (e.g., document upload, context retrieval) without modification. Because the RAG API does not validate the token's intended scope or audience, the request succeeds, allowing the attacker to read or inject documents into the RAG context that they should not have access to. A proof-of-concept demonstrating this token reuse is available in the SBA Research advisory, enabling rapid exploitation by security researchers or malicious actors with access to a LibreChat deployment. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 18, 2026
LibreChat 0.8.1-rc2 improperly issues JWT tokens to authenticated users for both the LibreChat API and RAG API without adequate scope separation or validation, enabling token reuse across API boundaries. An authenticated attacker with local access can exploit this misconfiguration to access or manipulate resources in the RAG API using credentials intended only for the main LibreChat API. This authentication bypass affects all deployments of LibreChat 0.8.1-rc2, with a proof-of-concept available via the SBA Research advisory (EUVD-2026-12813), though no active KEV exploitation has been reported at this time.
RemediationAI
Upgrade LibreChat to a patched version released after 0.8.1-rc2 (consult https://github.com/sbaresearch/advisories/tree/public/2025/SBA-ADV-20251205-01_LibreChat_RAG_API_Authentication_Bypass for exact recommended version). If immediate upgrade is not feasible, implement JWT validation middleware that enforces scope and audience claims at the RAG API gateway, rejecting any tokens lacking an explicit 'rag_api' audience claim. Additionally, configure the RAG API to use separate signing keys or key rotation policies distinct from the main LibreChat API to prevent token substitution. Until patching, restrict network access to the RAG API to internal-only connections and disable external RAG integration if not actively required.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
LibreChat is an open-source chat application that integrates with multiple backend APIs, including a dedicated Retrieval-Augmented Generation (RAG) API for document processing and context injection. The vulnerability stems from CWE-669 (Incorrect Resource Transfer Between Spheres), where JWT tokens generated for authenticated sessions in LibreChat 0.8.1-rc2 (identified via CPE cpe:2.3:a:librechat:librechat:*:*:*:*:*:*:*:*) are issued with insufficient granularity—tokens lack proper audience (aud) claims, scope restrictions, or API-specific validation. This allows a token issued for the primary API to be reused against the RAG API without the authorization layer detecting scope violations. The root cause reflects insufficient implementation of OAuth 2.0 and JWT best practices around token compartmentalization.
Know when Librechat gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
In LibreChat 0.8.1-rc2, a logged-in user obtains a JWT for both the LibreChat API and the RAG API.
Executive ViewAI
CVE-2026-33265 presents moderate security risk rated CVSS 6.3. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Related Vulnerabilities in LibreChat JWT and Authorization Flaws
View all 2A vulnerability in danny-avila/librechat version git 81f2936 allows for path traversal due to improper sanitization of f
An arbitrary file deletion vulnerability exists in danny-avila/librechat version v0.7.5-rc2, specifically within the /ap
LibreChat before v0.8.2-rc2 allows any authenticated user to execute shell commands as root inside the container through
LibreChat 0.7.9 lets an authenticated user turn off two-factor authentication on their own account without supplying a v
Stored cross-site scripting and tracker injection in LibreChat 0.8.0 and earlier allow a user who can create a chat to c
LibreChat is a ChatGPT clone with additional features. Rated high severity (CVSS 8.6), this vulnerability is remotely ex
LibreChat 0.8.1-rc2 has SSRF in the Actions feature that allows authenticated users to make the server perform requests
In danny-avila/librechat version git 0c2a583, there is an improper input validation vulnerability. Rated high severity (
A mass assignment vulnerability exists in danny-avila/librechat, affecting all versions. Rated high severity (CVSS 7.5),
Unbounded `key` and `value` parameters on the LibreChat 0.7.9 memory API (`POST /api/memories` and `PATCH /api/memories/
An unhandled exception in the danny-avila/librechat repository, version git 600d217, can cause the server to crash, lead
An improper access control vulnerability (IDOR) exists in the delete attachments functionality of danny-avila/librechat
EUVD-2026-12813
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB