Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS 2.0 and the low severity vector (AV:N/AC:H/AT:P/PR:L/UI:A with VC:L/VI:L and no integrity or availability impact) correctly reflect that this is information disclosure with constrained attack surface: requires network access, high complexity (multisite cluster setup), requires prior timing/preparation (AT:P), authenticated login, and user interaction. However, real-world risk is elevated beyond the score because Stripe API keys are highly sensitive - they grant access to payment data, customer PII, and financial transactions. An attacker with authenticated access to one site in a cluster can extract keys valid for all sites, enabling fraud, data theft, and lateral privilege escalation. The specificity of the multisite setup constraint (not all Discourse deployments use multisite) somewhat limits total affected population. EPSS data not provided; no KEV status or public POC identified, suggesting limited real-world exploitation. This is a legitimate but contained risk - patch promptly for any multisite Discourse cluster handling payments. |
| Exploit ScenarioDerived | An attacker gains authenticated access to one site (Site A) in a multisite Discourse cluster, either through credential reuse or social engineering. The attacker navigates to the payment or subscription settings page and observes that the interface displays Stripe API keys belonging to Site B, another organization's forum on the same cluster. The attacker copies these keys and uses them to query Stripe's API directly, accessing transaction history, customer lists, and financial data for Site B's customers. No exploit code is required; the leak is triggered by normal administrative UI interaction. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 31, 2026
Discourse versions 2026.1.0-2026.1.2, 2026.2.0-2026.2.1, and 2026.3.0 leak Stripe API keys across sites in multisite cluster deployments due to improper credential isolation in the discourse-subscriptions plugin, allowing authenticated users with UI access on one site to view payment credentials belonging to other sites within the same cluster. CVSS 2.0 reflects low severity (information disclosure only, requires authentication and user interaction), but the exposure of payment processor credentials carries material business risk. Patches are available in versions 2026.1.3, 2026.2.2, and 2026.3.0.
RemediationAI
Upgrade Discourse to patched versions: 2026.1.3 or later for the 2026.1 branch, 2026.2.2 or later for the 2026.2 branch, or 2026.3.0 or later for the 2026.3 branch. For multisite cluster operators, apply the patch across all site instances to ensure credential isolation is restored. No mitigation workaround is documented; patching is the required remediation. Consult the GitHub Security Advisory (https://github.com/discourse/discourse/security/advisories/GHSA-f866-8fcp-fgvv) and the upstream commit (https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80) for technical details and verification steps.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse is a Ruby-on-Rails-based discussion platform supporting multisite deployments, where multiple independent forum instances share infrastructure but should maintain isolated data contexts. The discourse-subscriptions plugin integrates Stripe payment processing by storing API keys (sensitive authentication material used to query and manage payment data). CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor) indicates the root cause: the plugin fails to properly namespace or isolate these keys per site, allowing Stripe credentials configured for Site A to be readable by authenticated users accessing Site B through the same multisite cluster. This is a context-confusion vulnerability specific to multisite architectures where shared backend caching or configuration stores are not properly scoped.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, the discourse-subscriptions plugin leaks stripe API keys across sites in a multisite cluster resulting in the potential for stripe related information to be leaked across sites within the same multisite cluster. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-17567
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB