Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
|
| Impact | While CVSS and EPSS scores are not available for this CVE, the practical risk is moderate to high based on multiple corroborating signals. The vulnerability has confirmed proof-of-concept details documented by Patchstack, indicating active discoverability and likely exploitability. The attack vector is network-based and requires low or no privileges, and complexity appears low given the nature of IDOR vulnerabilities. The technical impact is significant as it enables unauthorized data access and modification. However, the real-world risk depends on deployment scope: LatePoint is a WordPress plugin, so exposure is limited to organizations using this specific plugin version. The vulnerability affects a wide version range (up to 5.2.6), suggesting it may have existed for some time. The absence of KEV listing does not reduce concern given the public POC availability and practical exploitability. Organizations using LatePoint should prioritize patching, but enterprises not using this plugin face no direct risk. |
| Exploit ScenarioDerived | An attacker discovers a WordPress site running LatePoint and identifies the plugin is active. By intercepting or crafting HTTP requests to the booking or appointment management endpoints, the attacker modifies user-controlled parameters (such as appointment ID or customer ID) to values they do not own. Due to insufficient authorization checks, the application returns sensitive data or allows the attacker to view, modify, or cancel appointments belonging to other customers. The attacker can enumerate multiple IDs sequentially to extract customer contact information, payment details, or appointment schedules without authentication. A proof-of-concept demonstrating this parameter manipulation is publicly available via Patchstack, making exploitation straightforward for moderately skilled attackers. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
An authorization bypass vulnerability exists in LatePoint versions up to and including 5.2.6 that allows attackers to exploit incorrectly configured access control security levels through user-controlled key manipulation. This Insecure Direct Object Reference (IDOR) vulnerability enables attackers without proper authentication or authorization to access resources they should not have permission to view or modify. The vulnerability affects the LatePoint WordPress plugin and has been documented by Patchstack with proof-of-concept details available, making it a practical exploitation risk for unpatched installations.
RemediationAI
Update LatePoint to a patched version released after 5.2.6, if available from the plugin developer. Visit the official LatePoint documentation and Patchstack advisory (https://patchstack.com/database/Wordpress/Plugin/latepoint/vulnerability/wordpress-latepoint-plugin-5-2-6-insecure-direct-object-references-idor-vulnerability) to confirm the latest secure version and deployment instructions. As an interim workaround pending patch availability, restrict access to LatePoint administrative and booking interfaces using a Web Application Firewall (WAF) with rules to detect and block parameter tampering, enforce role-based access controls at the WordPress level, limit API endpoint access to authenticated users only, and implement audit logging on all appointment and resource access. Additionally, consider disabling LatePoint temporarily if not critical until a patched version is released. Database backups should be verified before applying patches to ensure recovery capability.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is rooted in CWE-639 (Authorization Bypass Through User-Controlled Key), a common access control flaw where applications fail to properly validate user permissions when object references (such as user IDs, appointment IDs, or resource identifiers) are passed as user-controllable parameters. LatePoint, identified by CPE cpe:2.3:a:latepoint:latepoint:*:*:*:*:*:*:*:*, is a WordPress plugin providing scheduling and booking functionality. The plugin fails to implement adequate server-side authorization checks, relying instead on weak or absent validation of user-supplied keys or identifiers. This allows attackers to enumerate or manipulate parameters (such as appointment IDs or customer records) to access data belonging to other users without proper authentication or authorization checks, which is a classic IDOR vulnerability pattern.
Know when Latepoint gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Authorization Bypass Through User-Controlled Key vulnerability in LatePoint LatePoint latepoint allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects LatePoint: from n/a through <= 5.2.6.
Executive ViewAI
CVE-2026-32533 presents notable security risk, a IDOR vulnerability rated CVSS 6.5. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
The LatePoint plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 5.0.12. Rate
The LatePoint plugin for WordPress is vulnerable to Arbitrary User Password Change via SQL Injection in versions up to,
The LatePoint Plugin plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a
Price tampering in the LatePoint WordPress booking plugin before 5.7.5 lets a remote unauthenticated visitor manipulate
Blind SQL injection in the LatePoint WordPress appointment-booking plugin (versions up to and including 5.6.3) lets remo
LatePoint WordPress plugin through 5.7.4 allows unauthenticated remote attackers who know a target customer's registered
Unauthenticated arbitrary shortcode execution in LatePoint (Appointment Booking Plugin - Calendar & Scheduling for WordP
Privilege escalation in the LatePoint appointment booking plugin for WordPress (all versions up to and including 5.7.3)
Privilege escalation in the LatePoint booking plugin for WordPress (versions ≤ 5.4.1) lets an authenticated user holding
Privilege escalation to Administrator in the LatePoint booking plugin for WordPress (versions up to and including 5.6.3)
Cross-Site Request Forgery (CSRF) vulnerability in Latepoint LatePoint allows Cross Site Request Forgery.9.91. Rated hig
Privilege escalation in the LatePoint Calendar Booking plugin for WordPress (versions up to and including 5.5.1) allows
EUVD-2026-15905
GHSA-4w94-x732-jcmm
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB