Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N) indicates a network-exploitable vulnerability with low attack complexity and no privileges required, which are concerning indicators. However, the impact is limited to integrity (modifications only) with no confidentiality or availability impact, and the scope is unchanged (within the vulnerable component only). While the CVSS score of 5.3 places this in the medium severity band, the real-world risk depends on exploitation probability and automatable impact. The absence of CISA KEV status suggests this vulnerability is not yet being actively exploited at scale, and the lack of publicly disclosed proof-of-concept code moderates the immediate risk. For WooCommerce store operators, the integrity impact is material because unauthorized modifications to currency settings could disrupt transactions, enable pricing fraud, or compromise store functionality. Organizations should prioritize patching, particularly if they operate high-transaction-volume stores, but this does not warrant emergency response procedures. |
| Exploit ScenarioDerived | An unauthenticated attacker could directly access the vulnerable authorization endpoint (likely a WordPress AJAX action or REST API route) and submit a crafted request to modify currency switcher settings, such as changing exchange rates, enabling or disabling specific currencies, or altering pricing configurations. Because the vulnerability requires no authentication, the attacker needs only knowledge of the vulnerable endpoint URL, which can be discovered through standard WordPress enumeration techniques or by reverse-engineering the plugin's JavaScript. The attacker could automate this attack against multiple WooCommerce stores, enabling price manipulation or availability attacks. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
The WBW Currency Switcher for WooCommerce plugin through version 2.2.5 contains an authorization bypass vulnerability that allows unauthenticated remote attackers to modify plugin settings and configurations without proper access controls. This vulnerability affects WordPress sites running the vulnerable plugin versions and could enable attackers to alter currency settings or manipulate store functionality. No patch is currently available for this vulnerability.
Earlier versions of this analysis (1)
A missing authorization vulnerability exists in WBW Currency Switcher for WooCommerce plugin (versions through 2.2.5) that allows unauthenticated attackers to modify data due to incorrectly configured access control security levels. The vulnerability has a CVSS score of 5.3 (medium severity) with a network-based attack vector requiring no authentication or user interaction, enabling attackers to perform unauthorized modifications to currency switcher settings or related e-commerce configurations. There is no indication this vulnerability is currently listed in CISA's KEV catalog or actively exploited in the wild, though the accessibility of the vulnerable endpoint (no authentication required) increases practical risk.
RemediationAI
Upgrade WBW Currency Switcher for WooCommerce to a patched version greater than 2.2.5 as soon as possible. Visit the plugin's page on wordpress.org or the vendor's website to download the latest version, then update via your WordPress admin dashboard. If a patched version is not yet available, consider temporarily disabling the plugin until a fix is released, and monitor the plugin repository for security updates. As an interim mitigation, restrict access to WooCommerce administrative pages using a Web Application Firewall (WAF) rule to allow only authenticated administrator IP addresses, and ensure your WordPress installation is fully updated with the latest security patches.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-862 (Missing Authorization), a class of access control flaws where an application fails to properly enforce authorization checks before performing sensitive operations. The WBW Currency Switcher for WooCommerce plugin (CPE: cpe:2.3:a:wbw:woo-currency:*:*:*:*:*:*:*:*) is a WordPress plugin designed to enable multi-currency functionality for WooCommerce stores. The root cause is an incorrectly configured access control security level that permits unauthenticated or unprivileged users to access administrative or sensitive functions, likely related to REST API endpoints or direct function calls that should be restricted to authenticated shop administrators. This is a common pattern in WordPress plugins where capability checks or nonce verification are omitted or misconfigured.
Know when Wbw Currency Switcher For Woocommerce gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Missing Authorization vulnerability in WBW Plugins WBW Currency Switcher for WooCommerce woo-currency allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WBW Currency Switcher for WooCommerce: from n/a through <= 2.2.5.
Executive ViewAI
CVE-2026-32410 presents moderate security risk, a missing authorization vulnerability rated CVSS 5.3. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-11927
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB