Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V13 - Configuration Secure default settings
|
| Impact | The CVSS 3.1 score of 5.3 (Medium severity) reflects the local attack vector (AV:L), low attack complexity (AC:L), and low privilege requirement (PR:L), indicating realistic exploitability by local users without special knowledge. The vulnerability carries moderate real-world risk: it requires local access (not network-exploitable), but the CVSS vector shows no user interaction required (UI:N) and the technical impact is confidentiality, integrity, and availability across the affected scope (C:L/I:L/A:L). The availability of vendor patches and disclosure via official GitHub security advisories suggests this is a known, prioritized issue without active mass exploitation reported. However, the absence of EPSS score and KEV status data in provided intelligence limits definitive exploitation probability assessment. For local threat models or shared systems, this warrants prompt patching; for internet-facing applications, this is lower priority relative to remote code execution vulnerabilities. |
| Exploit ScenarioDerived | A local user on a shared OpenClaw system identifies that the Chromium renderer sandbox is disabled due to improper configuration. They craft a malicious webpage or leverage a pre-existing renderer vulnerability (e.g., a use-after-free in the V8 engine) to achieve code execution within the renderer process. Because OS-level sandbox protections are absent, the attacker's code runs with the privileges of the OpenClaw process on the host, allowing file system access, credential theft, or lateral movement. No sandbox escape technique is required, making this a direct path from renderer exploit to host compromise. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 21, 2026
OpenClaw versions prior to 2026.2.21 contain an improper sandbox configuration vulnerability (CWE-1188) that allows local attackers with low privileges to execute arbitrary code on the host system by exploiting disabled OS-level sandbox protections in the Chromium browser container. The vulnerability does not require a sandbox escape, making exploitation straightforward for local users. A patch is available from the vendor, and the issue was reported by VulnCheck with references to GitHub security advisories and patch commits.
RemediationAI
Upgrade OpenClaw to version 2026.2.21 or later immediately, following the vendor security advisory at https://github.com/openclaw/openclaw/security/advisories/GHSA-43x4-g22p-3hrq. For systems that cannot be patched immediately, restrict local user access through OS-level access controls, disable local user shells where feasible, and monitor process creation events for suspicious renderer-spawned activity. Implement principle of least privilege for local accounts and consider containerizing or sandboxing OpenClaw deployments with hypervisor-level isolation to compensate for the disabled Chromium sandbox until patching is completed. Verify patch deployment by checking OpenClaw version and reviewing the referenced commit hashes.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from improper sandbox configuration in OpenClaw, which depends on Chromium's browser container isolation mechanisms. OpenClaw (cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:*) fails to enforce OS-level sandbox protections at the renderer process level, allowing attackers to exploit renderer-side vulnerabilities without needing to escape the sandbox first. This is classified as CWE-1188 (Initialization with Hard-Coded Network Resource Configuration Data), though the root cause is fundamentally a failure to enforce sandbox isolation boundaries in the Chromium renderer process. The disabled sandbox protections eliminate the intended containment layer that should prevent renderer exploits from affecting the host system.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
3DescriptionCVE.org
OpenClaw versions prior to 2026.2.21 contain an improper sandbox configuration vulnerability that allows attackers to execute arbitrary code by exploiting renderer-side vulnerabilities without requiring a sandbox escape. Attackers can leverage the disabled OS-level sandbox protections in the Chromium browser container to achieve code execution on the host system.
Executive ViewAI
CVE-2026-32046 presents moderate security risk rated CVSS 5.3. Exploitation could compromise the security of affected deployments. Proof-of-concept code is publicly available. A patch is available and should be applied during regular vulnerability management.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
Related Vulnerabilities in OpenClaw Multiple Authorization and Command Execution
View all 20Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
EUVD-2026-13941
GHSA-q94v-v6m9-jhq9
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB