Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate to GROWI platform
-
DeliveryInject malicious script into page/comment content
-
ExploitStore payload in application database
-
ExecutionVictim views compromised page
-
PersistScript executes in victim's browser session
-
ImpactAttacker gains session access or exfiltrates data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS vector (AV:N/AC:L/PR:L/UI:R/S:C) indicates network-accessible attack surface with low complexity, requiring only low-privilege authentication and user interaction. While the CVSS base score of 5.4 is medium, the real-world risk depends on deployment context: in organizations where GROWI is used for sensitive documentation or collaborative content, stored XSS poses significant risk because the payload persists and affects all users viewing the compromised content, not just the attacker. The scope-change (S:C) reflects potential impact beyond the vulnerable application. However, the requirement for authenticated access and user interaction (UI:R) limits opportunistic exploitation. No EPSS score, KEV confirmation, or public POC are available in the input data, suggesting this is a reported but not yet widely exploited vulnerability. Organizations should prioritize patching based on GROWI's role in their infrastructure and the sensitivity of data stored within. |
| Exploit ScenarioDerived | An authenticated user with content creation or editing privileges (e.g., wiki page author) crafts a malicious script and embeds it in a GROWI page or comment. When other authenticated users view the affected page, the script executes in their browsers with their session context, potentially stealing session cookies, redirecting to phishing pages, or performing unauthorized actions on their behalf. The attack requires the victim to visit the compromised page, but stored XSS ensures broad reach across all subsequent viewers. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Stored cross-site scripting in GROWI v7.4.6 and earlier allows authenticated users to inject malicious scripts that execute in other users' browsers, compromising confidentiality and integrity of user sessions. The vulnerability requires user interaction (clicking a link or viewing affected content) and authenticated access, resulting in a CVSS score of 5.4 (medium severity). No public exploit code or active KEV confirmation is indicated in available data.
RemediationAI
Users should upgrade GROWI to a patched version released after v7.4.6; consult the GROWI release notes at https://growi.co.jp/news/43/ to confirm the exact fix version available. As a preventive control pending patching, administrators should restrict access to GROWI to trusted users and monitor for suspicious content creation or modification, particularly in publicly visible pages. Ensure that GROWI is deployed behind authentication controls and consider implementing a Web Application Firewall (WAF) with XSS filtering rules to detect and block common injection patterns.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
GROWI is a wiki and knowledge management platform written in Node.js. The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), which indicates insufficient input sanitization or output encoding in the web application. Stored XSS occurs when user-supplied data is persisted in a backend storage system (database or file) and subsequently rendered in HTML context without proper escaping, allowing injected JavaScript to execute with the privileges of authenticated session holders. The affected product is identified by CPE cpe:2.3:a:growi,_inc.:growi:*:*:*:*:*:*:*:*, indicating all versions up to and including 7.4.6 are in scope.
Know when Growi gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Stored cross-site scripting vulnerability exists in GROWI v7.4.6 and earlier. If this vulnerability is exploited, an arbitrary script may be executed in a user's web browser.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
NoSQL injection vulnerability in GROWI versions prior to v4.2.20 allows a remote attacker to obtain and/or alter the inf
Cross-site request forgery (CSRF) vulnerability in GROWI v3.4.6 and earlier allows remote attackers to hijack the authen
Unauthenticated file disclosure in GROWI (all versions before 8.0.2) exposes private page attachments to any caller who
Remote denial of service via regular expression attack in GROWI allows unauthenticated network attackers to exhaust serv
Cross-user data exposure and tampering in GROWI v7.4.5 and earlier allows any authenticated user who learns a shared AI
Remote path traversal in GROWI v7.5.0 and earlier allows authenticated administrators to execute arbitrary EJS templates
Improper access control vulnerability in GROWI versions v4.2.2 and earlier allows a remote unauthenticated attacker to r
Directory traversal vulnerability in GROWI versions prior to v4.2.3 (v4.2 Series), GROWI versions prior to v4.1.12 (v4.1
Improper input validation in GROWI versions prior to v4.2.3 (v4.2 Series), GROWI versions prior to v4.1.12 (v4.1 Series)
GROWI v4.1.3 and earlier allow remote attackers to obtain information which is not allowed to access via unspecified vec
In WESEEK GROWI before 3.5.0, a remote attacker can obtain the password hash of the creator of a page by leveraging wiki
In WESEEK GROWI before 3.5.0, the site-wide basic authentication can be bypassed by adding a URL parameter access_token
EUVD-2026-22834
GHSA-w2qc-5jvx-3g3v
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB