Cube
CVE-2026-25958
HIGH
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain valid API token
-
ExploitCraft malicious request with token
-
ExecutionBypass authorization checks
-
ImpactEscalate privileges to higher role
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V2 - Validation and Business Logic Trusted input validation
|
| Exploitation Conditions | Valid API token required; vulnerable Cube versions 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14; authenticated user account necessary for token possession. |
| Impact | CVSS 7.7 (HIGH). Attack vector: Network. Complexity: Low. Privileges required: Low. User interaction: None. |
| Exploit ScenarioDerived | An attacker could exploit this flaw, privilege escalation. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 12, 2026
Privilege escalation in Cube.js versions 0.27.19 through 1.5.12 allows authenticated attackers to craft specially designed API requests that bypass access controls and gain elevated privileges within the application. This vulnerability affects Cube.js semantic layer deployments and requires only a valid API token to exploit, making it a risk to multi-tenant or role-based access control implementations. No patch is currently available for this HIGH severity issue.
Earlier versions of this analysis (1)
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. [CVSS 7.7 HIGH]
RemediationAI
Fixed in version 1.5.13. Restrict network access to the affected service where possible.
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Affects Cube.Js. Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Know when Cube gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Executive ViewAI
Cube semantic layer deployments are vulnerable to privilege escalation attacks when users possess valid API tokens, potentially allowing attackers to gain unauthorized administrative access to data applications and underlying data assets. Organizations using affected Cube versions (0.27.19 through 1.5.12, 1.4.1, and 1.0.13) face immediate risk of data exposure and unauthorized data manipulation without a vendor patch currently available.
Implement API gateway WAF rules to detect and block malformed or suspicious Cube API requests; enforce strict network segmentation restricting Cube access to authorized subnets only; disable public internet exposure of Cube instances; implement robust API token monitoring and alerting for anomalous authentication patterns; rotate all API tokens immediately and enforce shorter token expiration windows; implement database-level access controls to limit damage from compromised Cube instances; enable comprehensive audit logging of all data access through Cube.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Affected Products (CPE)GitHub Advisory
Unauthenticated snapshot disclosure in Brickcom Cube, Dome, Bullet, and Box IP cameras lets anyone reachable on the came
Unauthorized camera feed access affects Brickcom Cube, Dome, Bullet, and Box IP camera product lines due to factory-ship
cube-js is a headless business intelligence platform. Rated high severity (CVSS 8.8), this vulnerability is remotely exp
Cube is a semantic layer for building data applications. Rated high severity (CVSS 7.5), this vulnerability is remotely
Cube.js versions 1.1.17 through 1.5.12 and 1.4.x before 1.4.2 are vulnerable to denial of service attacks where an authe
GHSA-v226-32c7-x2v7
NVD
CVE.org
EPSS
Exploit-DB