Skip to main content

Jsonwebtoken CVE-2026-25537

HIGH
Access of Resource Using Incompatible Type (Type Confusion) (CWE-843)
2026-02-04 security-advisories@github.com GHSA-h395-gr6q-cpjc
7.5
CVSS 3.1 · GitHub Advisory
View

Attack ChainAIDerived

Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain

  1. Access
    Craft JWT with string-type nbf/exp claim
  2. Delivery
    Parser marks claim FailedToParse
  3. Exploit
    Validation treats as NotPresent
  4. Execution
    Bypass expiration check
  5. Impact
    Access protected resource

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V15 - Secure Coding and Architecture Type safety enforcement
MITRE ATT&CK

1 technique across 1 tactic: Execution

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Exploitation Conditions

jsonwebtoken library versions before 10.3.0 with validation enabled (validate_nbf=true or validate_exp=true) but claim not in required_spec_claims. No special configuration beyond standard JWT validation settings required.

Impact

CVSS 7.5 (HIGH). Attack vector: Network. Complexity: Low. Privileges required: None. User interaction: None. Public exploit/POC available.

Exploit ScenarioDerived

An attacker could exploit this vulnerability to bypass critical time-based security restrictions (like “Not Before” checks) and.

This Week Schedule remediation this week. Why: HIGH severity (CVSS 7.0-8.9).
Patch available 0.1% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 12, 2026

jsonwebtoken prior to version 10.3.0 allows attackers to bypass JWT time-based validation checks through type confusion when standard claims like nbf or exp are provided with incorrect JSON types. The library incorrectly treats malformed claims as absent rather than invalid, enabling bypass of critical security restrictions if validation is enabled but the claim is not explicitly marked as required. Public exploit code exists for this vulnerability.

Earlier versions of this analysis (1)
v1 Mar 12, 2026 - 21:54 CVSS 7.5

Jsonwebtoken versions up to 10.3.0 is affected by access of resource using incompatible type (type confusion) (CVSS 7.5).

RemediationAI

A vendor patch is available — apply it immediately. Fixed in version 10.3.0.. Restrict network access to the affected service where possible.

Affected Packages

cargo jsonwebtoken fix: 10.3.0

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in cargo

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability (CWE-843: Access of Resource Using Incompatible Type (Type Confusion)) affects Jsonwebtoken. jsonwebtoken is a JWT lib in rust. Prior to version 10.3.0, there is a Type Confusion vulnerability in jsonwebtoken, specifically, in its claim validation logic. When a standard claim (such as nbf or exp) is provided with an incorrect JSON type (Like a String instead of a Number), the library’s internal parsing mechanism marks the claim as “FailedToParse”. Crucially, the validation logic treats this “FailedToParse” state identically to “NotPresent”. This means that if a check is enabled (like: v

Know when Jsonwebtoken gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

GitHub Advisory PRIMARY 7.5 HIGH
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Red Hat 7.5 MEDIUM

Primary rating from GitHub Advisory.

CVSS VectorGitHub Advisory

Attack Vector
Network
Attack Complexity
Low
Privileges Required
None
User Interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None

Lifecycle Timeline

3
PoC Detected
Feb 11, 2026 - 19:13 vuln.today
Public exploit code
Patch released
Feb 11, 2026 - 19:13 nvd
Patch available
CVE Published
Feb 04, 2026 - 22:15 nvd
HIGH 7.5

DescriptionGitHub Advisory

jsonwebtoken is a JWT lib in rust. Prior to version 10.3.0, there is a Type Confusion vulnerability in jsonwebtoken, specifically, in its claim validation logic. When a standard claim (such as nbf or exp) is provided with an incorrect JSON type (Like a String instead of a Number), the library’s internal parsing mechanism marks the claim as “FailedToParse”. Crucially, the validation logic treats this “FailedToParse” state identically to “NotPresent”. This means that if a check is enabled (like: validate_nbf = true), but the claim is not explicitly marked as required in required_spec_claims, the library will skip the validation check entirely for the malformed claim, treating it as if it were not there. This allows attackers to bypass critical time-based security restrictions (like “Not Before” checks) and commit potential authentication and authorization bypasses. This issue has been patched in version 10.3.0.

Executive ViewAI

Why It Matters

A type confusion vulnerability in the jsonwebtoken Rust library could allow attackers to bypass critical security validations (such as token expiration or not-before checks) by submitting malformed JWT claims. Organizations using affected versions of this library in authentication or authorization systems face potential unauthorized access risks.

Business Impact: High
Compensating Controls

Apply vendor patch. If immediate patching is not possible: implement strict input validation at the application layer to reject JWTs with non-numeric standard claims (nbf, exp, iat); enable WAF rules to detect and block malformed JWT payloads; monitor authentication logs for unusual claim validation failures; consider network segmentation to limit lateral movement from compromised tokens.

Threat Intelligence Overview

EPSS Score
0.1%
Top 75% exploitable
Exploit
POC
Public exploit code exists
Data Quality
4 sources
Confidence: Medium

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity HIGH
CISA KEV No
Public POC Yes
EPSS 0.1%
Patch available Yes
Active threat No
Deciding rule
HIGH severity (CVSS 7.0-8.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Out-of-Cycle
Exploitation· derived
Poc
System Exposure· derived
Open
Automatable· derived
Yes
Human Impact
High

Priority Score

58
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +38
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

A buffer overflow occurs when a program writes more data to a memory buffer than it was allocated to hold, causing the excess data to spill into adjacent memory regions.

Affected Products (CPE)GitHub Advisory

cpe:2.3:a:keats:jsonwebtoken:*:*:*:*:*:rust:*:*

Vendor StatusVendor

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy