Iotdb
CVE-2026-24713
CRITICAL
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend malformed input to IoTDB network interface
-
ExploitBypass input validation checks
-
ImpactExecute arbitrary code with database privileges
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V2 - Validation and Business Logic Input validation, allowlisting
|
| Exploitation Conditions | Apache IoTDB versions 1.0.0–1.3.6 or 2.0.0–2.0.6 with network accessibility enabled. No authentication required for remote exploitation against default configurations. |
| Impact | CVSS 9.8. Multiple attack vectors against IoT data infrastructure. |
| Exploit ScenarioDerived | Attacker sends crafted input to IoTDB service, exploiting validation weakness. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 12, 2026
Input validation vulnerability in Apache IoTDB from 1.0.0 before 1.3.7 and from 2.0.0 before 2.0.7. Second critical CVE affecting the IoT database.
Earlier versions of this analysis (1)
Input validation flaw in Apache IoTDB.
RemediationAI
Update to IoTDB 1.3.7 or 2.0.7.
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in maven
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-20 improper input validation. Second critical vulnerability in Apache IoTDB.
Know when Iotdb gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Input Validation vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Executive ViewAI
A critical input validation vulnerability in Apache IoTDB (CVSS 9.8) affects versions 1.0.0-1.3.6 and 2.0.0-2.0.6, potentially allowing attackers to execute arbitrary code or compromise data integrity. Organizations running affected IoTDB instances face immediate risk of system compromise; however, current exploit activity is minimal (0.1% EPSS). Immediate action is required to inventory affected systems and implement interim protections pending patch availability.
Until vendor patch is released: (1) Implement network segmentation to restrict IoTDB access to trusted internal systems only; (2) Deploy WAF rules to validate and sanitize input to IoTDB API endpoints; (3) Disable unnecessary IoTDB features or external connectivity if operationally feasible; (4) Enable comprehensive logging and monitoring for suspicious IoTDB activity; (5) Maintain current backups and establish rapid recovery procedures; (6) Consider temporary service shutdown if no compensating controls adequately reduce risk.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Affected Products (CPE)CVE.org
Related Vulnerabilities in Apache IoTDB Critical Input Validation
View all 2A flaw was found in FasterXML Jackson Databind, where it did not have entity expansion secured properly. Rated high seve
Remote Code Execution with untrusted URI of UDF vulnerability in Apache IoTDB. Rated critical severity (CVSS 9.8), this
Deserialization of Untrusted Data vulnerability in Apache IoTDB.13.0 through 0.13.4. Rated critical severity (CVSS 9.8),
Improper Authentication vulnerability in Apache Software Foundation Apache IoTDB.13.0 through 0.13.3. Rated critical sev
An issue was found in Apache IoTDB .9.0 to 0.9.1 and 0.8.0 to 0.8.2. Rated critical severity (CVSS 9.8), this vulnerabil
Incorrect Authorization vulnerability in Apache Software Foundation Apache IoTDB.13.0 before 0.13.3. Rated high severity
Apache IoTDB version 0.13.0 is vulnerable by session id attack. Rated high severity (CVSS 8.8), this vulnerability is re
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerabili
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerabili
A vulnerability in Apache IoTDB.3.3 through 1.3.4, from 2.0.1-beta through 2.0.4. Rated high severity (CVSS 7.5), this v
Improper Authentication vulnerability in Apache Software Foundation Apache IoTDB.13.0 before 0.13.3. Rated high severity
GHSA-6w48-2g9j-v9q5
NVD
CVE.org
EPSS
VulDB
Exploit-DB