Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | Although no CVSS score or EPSS score is published, the vulnerability's risk profile is elevated by several factors: (1) It is a Stored XSS, not Reflected XSS, meaning the malicious payload persists and affects all users viewing the compromised content, including administrators; (2) The affected product is a WordPress plugin, which typically operates with privileged access to site content and user data; (3) Patchstack's public disclosure and ENISA EUVD assignment (EUVD-2026-15565) indicate active awareness in the security community. The lack of assigned CVSS/EPSS may indicate late-stage CVE assignment or provisional scoring. Without known KEV status or public POC, the real-world exploitation rate is currently unknown, but the technical simplicity of XSS attacks and the plugin's likely user base suggest moderate-to-high actual exploitation risk. Organizations using The Grid should treat this as a high-priority patch based on the stored XSS nature and plugin prevalence. |
| Exploit ScenarioDerived | An attacker gains low-privilege access to a WordPress site using The Grid plugin (e.g., via a compromised contributor account, weak credentials, or another vulnerability). The attacker navigates to a Grid configuration or content creation interface and injects a malicious JavaScript payload (e.g., <script>fetch('/wp-admin/user-new.php?action=createuser&user=hacker&pass=password123')</script>) into a grid cell, grid title, or metadata field that is rendered without sanitization. When administrators or site visitors view the affected grid on the frontend or backend, the injected script executes in their browsers with their privileges, potentially allowing account creation, session hijacking, or credential theft. No complex exploitation technique is required; basic JavaScript and knowledge of WordPress admin endpoints are sufficient. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Stored Cross-Site Scripting (XSS) vulnerability exists in Theme-one's The Grid WordPress plugin versions prior to 2.8.0, allowing attackers to inject and persist malicious scripts that execute in the browsers of other users viewing affected pages. An authenticated or unauthenticated attacker can exploit improper input neutralization during web page generation to inject arbitrary JavaScript code. While no CVSS score, EPSS probability, or KEV status has been assigned, the vulnerability is confirmed by Patchstack and carries significant risk given the stored nature of the XSS and the plugin's widespread WordPress ecosystem adoption.
RemediationAI
Immediately upgrade Theme-one The Grid to version 2.8.0 or later, which contains the fix for this Stored XSS vulnerability. Site administrators should log into their WordPress dashboard, navigate to Plugins > Installed Plugins, locate "The Grid," and click "Update" if available. For sites unable to patch immediately, implement the following temporary mitigations: (1) Disable The Grid plugin until the patch is deployed; (2) Restrict access to The Grid configuration and content creation pages to trusted administrators only via IP whitelisting or authentication plugins; (3) Deploy a Web Application Firewall (WAF) with rules to detect and block common XSS payloads in POST/GET parameters; (4) Enable WordPress security plugins with output escaping enhancements; (5) Audit existing grid content for malicious scripts and sanitize if necessary. Refer to the Patchstack advisory at https://patchstack.com/database/Wordpress/Plugin/the-grid/vulnerability/wordpress-the-grid-plugin-2-8-0-cross-site-scripting-xss-vulnerability for detailed patch notes.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Grid (cpe:2.3:a:theme-one:the_grid:*:*:*:*:*:*:*:*) is a WordPress plugin that generates dynamic grid-based layouts. The vulnerability stems from CWE-79 (Improper Neutralization of Input During Web Page Generation), meaning user-supplied input is not properly sanitized or escaped before being rendered in HTML output. Rather than implementing robust input validation and context-aware output encoding (HTML entity encoding, JavaScript escaping, or Content Security Policy), the plugin directly incorporates user input into page generation logic. This allows attackers to bypass client-side and server-side filtering, resulting in persistent XSS payloads that execute whenever affected content is viewed.
Know when The Grid gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Theme-one The Grid the-grid allows Stored XSS.This issue affects The Grid: from n/a through < 2.8.0.
Executive ViewAI
CVE-2026-24370 presents notable security risk, a cross-site scripting vulnerability rated CVSS 6.5. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Related Vulnerabilities in WordPress Plugin XSS Vulnerabilities
View all 5Privilege escalation in The Grid WordPress plugin (versions ≤ 2.7.9.1) permits any authenticated subscriber-level user t
The Grid WordPress plugin versions prior to 2.8.0 contain a missing authorization vulnerability (CWE-862) that allows at
EUVD-2026-15565
GHSA-ghg5-chx7-mwc9
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB