Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V3 - Web Frontend Security Anti-CSRF tokens, SameSite cookies
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N) indicates this is a low-complexity network-based attack requiring user interaction but affecting only confidentiality with no integrity or availability impact. The low CVSS score of 4.3 reflects limited direct damage potential—the attacker can enumerate follow relationships and perform follow manipulation, but cannot cause system outages or widespread data corruption. However, this assessment underestimates real-world risk when considering SSVC factors: exploitation is likely automatable through simple HTTP requests, the technical impact enables user privacy violation and social engineering vectors, and public CSRF exploitation techniques are well-established. The lack of authentication requirement (PR:N) combined with UI requirement suggests this fits a targeted phishing or malicious website scenario rather than widespread automated exploitation. Given that wpDiscuz is installed on thousands of WordPress sites and follow data can enable social engineering attacks, this vulnerability warrants prioritization for sites handling sensitive communities, but does not represent critical infrastructure risk. |
| Exploit ScenarioDerived | An attacker creates a malicious website or sends a phishing email containing an invisible iframe or JavaScript code that makes CSRF requests to a target WordPress site running vulnerable wpDiscuz. When a logged-in user visits the attacker's site, the hidden request automatically executes on their behalf, following or unfollowing accounts the attacker specifies and enumeration follow lists without the user's knowledge. For example, a bad actor could systematically enumerate all followers of a competitor's account or manipulate follows to amplify certain accounts in a user's social feed. Since the attack requires UI interaction (user visiting the malicious site while logged into WordPress) but has low complexity and network accessibility, it represents a practical threat in targeted campaigns against high-value accounts or during social engineering attacks. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
wpDiscuz before version 7.6.47 contains a cross-site request forgery (CSRF) vulnerability in the getFollowsPage() function that allows unauthenticated attackers to trigger unauthorized actions on behalf of legitimate users without valid nonce validation. An attacker can exploit this by crafting malicious requests to enumerate user follow relationships and manipulate follow data, potentially exposing private social graph information and allowing unauthorized modifications to user follow lists. While the CVSS score of 4.3 indicates low to moderate severity with limited direct impact, the vulnerability requires user interaction (UI:R) but has network-accessible attack surface with no authentication requirement, making it practically exploitable in targeted phishing campaigns.
RemediationAI
The primary remediation is to upgrade wpDiscuz to version 7.6.47 or later immediately via the WordPress Plugins dashboard (Plugins > Installed Plugins > wpDiscuz > Update). This patch version implements proper nonce validation in the getFollowsPage() function and other affected AJAX handlers. For sites unable to update immediately, temporarily disable the follow feature by adding a code filter to disable the AJAX endpoints, or restrict access to wpDiscuz functionality via WAF rules blocking requests to /wp-admin/admin-ajax.php?action=wpdiscuz_get_follows_page. Additionally, audit user follow relationships for unauthorized changes by reviewing WordPress user metadata and wpDiscuz follow tables for suspicious modifications made during the vulnerability window. Verify that WordPress security headers (CSP, X-Frame-Options) are properly configured to provide defense-in-depth against CSRF-style attacks.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
wpDiscuz is a WordPress plugin that provides discussion and commenting functionality with social features including user following mechanisms. The vulnerability exists in the getFollowsPage() function, which is part of the plugin's AJAX handler for follow-related operations. The root cause falls under CWE-352 (Cross-Site Request Forgery), indicating that the application fails to implement proper CSRF token validation (nonce verification) before processing state-changing requests. WordPress typically protects against CSRF through wp_nonce_field() and wp_verify_nonce() functions, but the affected code path bypasses these security checks. The follows functionality likely interacts with user metadata storage and relationship tables in the WordPress database, making improper access control particularly concerning for privacy-sensitive follow/unfollow relationships.
Know when Wpdiscuz gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
wpDiscuz before 7.6.47 contains a cross-site request forgery vulnerability in the getFollowsPage() function that allows attackers to trigger unauthorized actions without nonce validation. Attackers can craft malicious requests to enumerate follow relationships and manipulate user follow data by exploiting the missing CSRF protection in the follows page handler.
Executive ViewAI
Organizations using wpDiscuz before 7.6.47 should be aware of moderate risk from CVE-2026-22215, a cross-site request forgery vulnerability rated CVSS 4.3. Users could be tricked into performing unintended actions. A patch is available and should be applied during regular vulnerability management.
Apply vendor patch. If patching is delayed: implement SameSite cookie attributes and anti-CSRF tokens.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Request Forgery exploits the automatic credential inclusion behavior of web browsers.
Related Vulnerabilities in wpDiscuz Multiple Security Vulnerabilities
View all 14A Remote Code Execution vulnerability exists in the gVectors wpDiscuz plugin 7.0 through 7.0.4 for WordPress, which allo
A SQL injection issue in the gVectors wpDiscuz plugin 5.3.5 and earlier for WordPress allows remote attackers to execute
The Comments - wpDiscuz plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including
Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team Comments - wpDiscuz plugin <= 7.6.11 versions. Rated hi
Auth. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, low attack complexity. No vendor patch
The Comments - wpDiscuz WordPress plugin through 7.3.0 does not properly sanitise or escape the Follow and Unfollow mess
The wpDiscuz WordPress plugin before 7.3.4 does check for CSRF when adding, editing and deleting comments, which could a
EUVD-2026-11752
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB