Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V6 - Authentication IP-independent access control
|
| Impact | While the CVSS score of 5.3 indicates medium severity with network-based attack vector and low attack complexity, the real-world risk profile requires nuanced assessment. The attack vector (AV:N) and lack of required privileges (PR:N) mean any unauthenticated attacker on the network can exploit this, making it trivially easy to execute. The integrity impact (I:L) is limited but meaningful—attackers can circumvent rate limiting to conduct comment spam, denial-of-service attacks through comment flooding, or bypass IP-based bans to re-attack compromised sites. The absence of confidentiality impact (C:N) limits exposure severity. However, the real-world priority depends on whether the target site relies on IP-based rate limiting as a primary security control; sites using additional protections (CAPTCHA, token-based rate limiting, user-agent validation) face lower risk. No public exploit code is currently confirmed in widely-available repositories, but the simplicity of the attack (modifying HTTP headers) means exploitation requires minimal sophistication and could be automated. The lack of authentication requirement and high automatable nature suggest this is a practical vulnerability for attackers targeting WordPress installations with comment abuse vectors. |
| Exploit ScenarioDerived | An attacker seeks to spam a WordPress site's comments section, but the site has implemented IP-based rate limiting allowing only 10 comments per IP address per hour. The attacker exploits wpDiscuz by sending HTTP requests with manipulated X-Forwarded-For headers (e.g., 'X-Forwarded-For: 192.0.2.1', 'X-Forwarded-For: 192.0.2.2') in each request, causing the vulnerable getIP() function to return a different IP address for each request. This allows the attacker to bypass the rate limit entirely and submit unlimited spam comments. Alternatively, the attacker could exploit this to bypass an IP-based ban, allowing them to re-attack a previously blacklisted IP address by spoofing a new identity. The attack requires only network access and HTTP header manipulation, achievable through any HTTP client or browser console, making it highly accessible to low-skill attackers. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
wpDiscuz before version 7.6.47 contains an IP spoofing vulnerability in the getIP() function that allows unauthenticated attackers to spoof their IP address by manipulating HTTP headers (HTTP_CLIENT_IP and HTTP_X_FORWARDED_FOR). This enables circumvention of IP-based rate limiting and ban enforcement mechanisms, allowing attackers to bypass security controls that rely on IP-based detection. The vulnerability has a CVSS score of 5.3 with low attack complexity and no authentication required, making it easily exploitable in network environments.
RemediationAI
The primary remediation is to upgrade wpDiscuz to version 7.6.47 or later immediately, which includes fixes to the getIP() function to properly validate and filter HTTP headers. This update should be applied through the WordPress plugin management dashboard or manually via the official plugin repository. Until patching is feasible, site administrators should implement compensating controls: configure the WordPress site to reject or ignore HTTP_CLIENT_IP and HTTP_X_FORWARDED_FOR headers at the web server level unless connections originate from known legitimate proxy infrastructure, implement rate limiting at the reverse proxy or WAF layer rather than relying solely on application-level IP-based controls, enforce additional CAPTCHA or token-based rate limiting on comment submission forms, and monitor comment activity logs for suspicious patterns such as rapid-fire submissions from varied apparent IPs. Sites using a reverse proxy (nginx, Apache mod_proxy, or cloud WAF) should ensure proper configuration to pass only legitimate client IP information and ignore client-supplied headers.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the wpDiscuz plugin's getIP() function, which improperly validates the source of IP address information by trusting untrusted HTTP headers without verifying their legitimacy. The root cause is classified under CWE-348 (Clipped Characters in Identifiers with Security Implications), which in this context refers to improper handling of user-controllable input headers that should not be trusted for security-critical decisions. The plugin fails to implement proper IP validation by checking whether the X-Forwarded-For and Client-IP headers come from legitimate proxy servers or load balancers, instead accepting any value provided by a client. This is a common misconfiguration in WordPress plugins that do not account for the difference between direct client connections and connections through legitimate reverse proxies. The affected product is wpDiscuz (CPE: cpe:2.3:a:wpdiscuz:wpdiscuz), a WordPress commenting plugin used across thousands of installations.
Know when Wpdiscuz gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
wpDiscuz before 7.6.47 contains an IP spoofing vulnerability in the getIP() function that allows attackers to bypass IP-based rate limiting and ban enforcement by trusting untrusted HTTP headers. Attackers can set HTTP_CLIENT_IP or HTTP_X_FORWARDED_FOR headers to spoof their IP address and circumvent security controls.
Executive ViewAI
Organizations using wpDiscuz before 7.6.47 should be aware of moderate risk from CVE-2026-22201 rated CVSS 5.3. Exploitation could compromise the security of affected deployments. A patch is available and should be applied during regular vulnerability management.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Related Vulnerabilities in wpDiscuz Multiple Security Vulnerabilities
View all 14A Remote Code Execution vulnerability exists in the gVectors wpDiscuz plugin 7.0 through 7.0.4 for WordPress, which allo
A SQL injection issue in the gVectors wpDiscuz plugin 5.3.5 and earlier for WordPress allows remote attackers to execute
The Comments - wpDiscuz plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including
Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team Comments - wpDiscuz plugin <= 7.6.11 versions. Rated hi
Auth. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, low attack complexity. No vendor patch
The Comments - wpDiscuz WordPress plugin through 7.3.0 does not properly sanitise or escape the Follow and Unfollow mess
The wpDiscuz WordPress plugin before 7.3.4 does check for CSRF when adding, editing and deleting comments, which could a
EUVD-2026-11746
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB