Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as admin
-
ExploitSend crafted request with SQL payload in 'id' parameter
-
ExecutionSQL injection in plugin script
-
ImpactExtract sensitive database information
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Parameterized queries, prepared statements
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Persistence The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The attacker must be authenticated as an administrator or a user with the 'manage_options' capability on the WordPress site. The vulnerable 'id' parameter must be present in requests to scripts such as sms_campaign.php, class-abandonedcart.php, or SMSAlert-wc-order-sms.php. The attack is network-based and requires no user interaction. Default configurations are affected, but only admin-level users can trigger the vulnerability. |
| Impact | The CVSS score is 4.9 (medium) with a vector indicating network attack vector, low complexity, high privileges required (admin), no user interaction, and a confidentiality impact only. This means an attacker must already have admin-level access to the WordPress site to exploit it, which limits the attack surface. No EPSS or KEV data is available, suggesting low exploitation likelihood. However, if an attacker obtains admin credentials (e.g., via phishing or credential theft), they can extract the entire database. The SSVC decision would rate exploitation status as 'none', automatable as 'yes' (for an admin), and technical impact as 'high' (data exfiltration). Overall, it is a moderate priority for sites with strict admin access controls. |
| Exploit ScenarioDerived | An attacker who has obtained administrator credentials to a vulnerable WordPress site sends a crafted HTTP request to the vulnerable endpoint with a malicious SQL payload in the 'id' parameter. The injection allows the attacker to extract the entire WordPress database, including user passwords, customer data, and WooCommerce order details. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 28, 2026
SQL injection in the SMS Alert WordPress plugin allows authenticated administrators to extract sensitive database information. Affected versions up to and including 3.9.7 are vulnerable via the 'id' parameter. No active exploitation or public exploit has been reported as of this analysis.
RemediationAI
Upgrade the plugin to the latest patched version (likely 3.9.8 or higher) as soon as possible. A fix has been committed to the WordPress plugin repository as shown in the changeset reference. As a workaround, limit administrator access to only trusted users, enforce strong passwords, and consider enabling two-factor authentication for WordPress admin accounts. No other workarounds exist short of disabling or removing the plugin entirely.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The SMS Alert plugin integrates with WooCommerce for SMS notifications, OTP, and abandoned cart recovery. The vulnerability is a classic SQL injection (CWE-89) in multiple PHP scripts, including sms_campaign.php and class-abandonedcart.php, where the 'id' parameter is concatenated into SQL queries without proper escaping or prepared statements. The CPE (cpe:2.3:a:cozyvision1:sms_alert_-_sms_&_otp_for_woocommerce,_order_notifications_&_abandoned_cart_recovery:*:*:*:*:*:*:*) confirms all versions up to the fixed one are affected.
Know when Wordpress Plugin gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Requires admin authentication (PR:H), low attack complexity, no user interaction, only confidentiality impact.
Primary rating from Vendor (Wordfence).
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The SMS Alert - SMS & OTP for WooCommerce, Order Notifications & Abandoned Cart Recovery plugin for WordPress is vulnerable to generic SQL Injection via the 'id' parameter in all versions up to, and including, 3.9.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
SQL injection exploits the way applications construct database queries by mixing user input directly into SQL statements.
More in Wordpress Plugin
View allThe Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
SQL injection in the NotificationX WordPress plugin (versions up to and including 2.8.2) allows unauthenticated remote a
The POST SMTP Mailer - Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress i
The MasterStudy LMS WordPress Plugin - for Online Courses and Education plugin for WordPress is vulnerable to union base
The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘hash’ parameter in
EUVD-2026-49710
GHSA-87p3-j4x9-9hrq
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB