Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessHost malicious CSRF page
-
DeliveryLure logged-in admin to visit
-
ExploitForge request to unprotected AJAX action
-
ExecutionInject stored script into post
-
ImpactScript executes in visitors' browsers
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires that the WOLF plugin (version below 1.1.0) is installed and active, and that a logged-in administrator with post-authoring rights is socially engineered into triggering the attacker's cross-site request while their session is valid (UI:R). The specific enabling weakness is the missing nonce AND capability check on one WOLF AJAX action, which allows the forged request to be processed. Limiting factors: the attack cannot succeed without an authenticated admin's active session and interaction, so it is not a direct unauthenticated compromise despite PR:N - the 'unauthenticated attacker' initiates the request but relies entirely on the victim admin's privileges. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L, base 7.1) reflects network reach and no attacker privileges but requires user interaction - the admin must be lured into visiting a malicious page - which meaningfully lowers real-world exploitability. The scope change (S:C) accounts for script executing in victims' browsers beyond the vulnerable app. Signals conflict on urgency: publicly available exploit code raises capability, yet EPSS is only 0.12% (2nd percentile) and there is no KEV listing, suggesting low observed exploitation volume - consistent with the UI:R dependency and the niche footprint of a single plugin. No SSVC decision data was provided in the input. Net assessment: a legitimate patch-soon issue for sites running WOLF, but not an emergency compared with unauthenticated, no-interaction WordPress flaws. |
| Exploit ScenarioDerived | An attacker crafts a web page hosting a hidden auto-submitting form that fires the unprotected WOLF AJAX action, then lures a logged-in WordPress administrator to visit it (e.g., via a phishing link). The forged request, carrying the admin's cookies, writes attacker-controlled JavaScript into a post; that script then executes in the browser of every subsequent visitor to the post. Public exploit code for this flow is available via WPScan. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 30, 2026
Stored Cross-Site Scripting in the WOLF WordPress plugin before 1.1.0 lets an unauthenticated attacker persist malicious script into a post by exploiting a CSRF-exposed AJAX action lacking nonce and capability checks. Because a logged-in administrator must be tricked into triggering the request (UI:R), exploitation is CSRF-driven rather than direct, but a successful attack injects attacker-controlled JavaScript that executes in the context of anyone viewing the affected post. Publicly available exploit code exists (reported by WPScan), though the EPSS score is very low (0.12%, 2nd percentile) and it is not on the CISA KEV list.
RemediationAI
Vendor-released patch: upgrade the WOLF plugin to version 1.1.0 or later, which introduces the missing nonce and capability checks on the affected AJAX action; this is the primary and complete fix. If immediate upgrade is not possible, deactivate the WOLF plugin until it can be updated, since the vulnerable AJAX action is exposed while the plugin is active. As additional compensating controls, deploy a WAF rule to block cross-origin POSTs to admin-ajax.php for the affected action and require admins to avoid clicking untrusted links during authenticated sessions - noting that WAF filtering of admin-ajax traffic can produce false positives against legitimate plugin AJAX calls. Refer to the WPScan advisory (https://wpscan.com/vulnerability/ba3b8f4a-772f-42ad-9c67-5623406118c1/) for confirmation of the fixed version.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is the WOLF plugin for WordPress, a PHP-based CMS whose admin-facing actions are routed through the wp-admin AJAX endpoint (admin-ajax.php). WordPress security relies on per-request nonces (anti-CSRF tokens) and current_user_can() capability checks to authorize privileged operations; the vulnerable AJAX action omits both, so a forged cross-origin request carrying an authenticated admin's session cookies is accepted as legitimate. The root cause maps to CWE-79 (Improper Neutralization of Input During Web Page Generation), compounded by a missing-CSRF-protection weakness (CWE-352 class) that turns a nonce gap into a stored-XSS write primitive. The CPE (cpe:2.3:a:unknown:wolf:*) identifies the product generically as 'wolf' with an unknown vendor, reflecting limited registry metadata.
Know when Wolf gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Network CSRF with no attacker auth (PR:N) but requires admin interaction (UI:R); stored XSS runs in victim browsers so scope changes (S:C) with limited C/I/A impact.
Primary rating from Vendor (WPScan).
CVSS VectorVendor: WPScan
Lifecycle Timeline
4DescriptionCVE.org
The WOLF WordPress plugin before 1.1.0 does not perform a nonce or capability check on one of its AJAX actions, allowing an unauthenticated attacker to trick a logged-in administrator into writing arbitrary content, including a malicious script, into a post via a cross-site request, resulting in stored Cross-Site Scripting.
Executive ViewAI
The WOLF WordPress plugin prior to version 1.1.0 contains a stored cross-site scripting vulnerability allowing attackers to inject malicious scripts into posts, potentially compromising visitor data and damaging site integrity. Publicly available exploit code exists, though current exploitation probability remains low (EPSS 0.1%). Organizations should prioritize patching within 7 days to prevent opportunistic exploitation as awareness of the vulnerability grows.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
SQL injection vulnerability in the RealMag777 WOLF bulk-editor WordPress plugin (versions up to 1.0.8.7) that allows aut
Blind SQL injection in the PluginUs.Net WOLF bulk-editor WordPress plugin, affecting all versions through 1.1.1, allows
EUVD-2026-50120
GHSA-r4j4-29v7-6qph
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB