Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain low-privileged WP account
-
ExploitSend request to Surfer plugin endpoint
-
ExecutionMissing authorization check bypassed
-
ImpactRead or modify restricted plugin data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated low-privileged account on a WordPress site running the Surfer plugin version n/a through 1.8.0.744 (PR:L). The flaw is an incorrectly configured access-control check on plugin functionality, so any authenticated user can reach the affected endpoint over the network without user interaction. Limiting factors: the attacker must first hold valid credentials (open registration or an existing low-tier role makes this trivial, but a locked-down site with no low-privilege accounts raises the bar), and impact is confined to low-level unauthorized data read/modification rather than full site takeover. |
| Impact | This is a moderate-severity Missing Authorization flaw (CWE-862) in the Surfer WordPress plugin, rated CVSS 5.4 via vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N. The network vector and low attack complexity make it easy to reach, but PR:L means an attacker must already hold a low-privileged authenticated account (e.g. subscriber/contributor), which meaningfully constrains real-world risk. Impact is limited to low confidentiality and low integrity with no availability effect and no scope change, consistent with an unauthorized actor reaching functionality that should be access-controlled rather than full compromise. No EPSS score, KEV listing, or POC was provided in the input: there is no public exploit identified at time of analysis and no evidence of active exploitation, so this reads as a real-but-not-urgent patch-management item rather than an emergency. The signals are internally consistent - the authenticated, limited-impact CVSS matches a broken-access-control issue - so there is no major conflict to flag, though the absence of EPSS/KEV/POC data means exploitation likelihood is an inference, not a measured value. |
| Exploit ScenarioDerived | An attacker who has registered or obtained a low-privileged account on a WordPress site running Surfer ≤1.8.0.744 sends a crafted request directly to a plugin endpoint that fails to verify the caller's authorization level. Because the access-control check is missing, the attacker reaches functionality or data meant for higher-privileged users, enabling limited unauthorized read or modification. No public proof-of-concept was provided in the source data. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 19, 2026
Missing authorization in the Surfer WordPress plugin through 1.8.0.744 lets an authenticated low-privileged user exploit an incorrectly configured access-control check to read or modify limited site data over the network without user interaction. The issue is rated CVSS 5.4 (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N), and no public exploit was identified at time of analysis.
RemediationAI
No vendor-released patch is identified in the provided data; consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/surferseo/vulnerability/wordpress-surfer-plugin-1-8-0-744-broken-access-control-vulnerability?_s_id=cve and upgrade Surfer to a vendor-confirmed fixed release newer than 1.8.0.744 when available. If an immediate upgrade is not possible, deactivate or remove the Surfer plugin if its SEO functionality is not essential (trade-off: loss of plugin features), restrict and audit low-privileged accounts and disable open registration to reduce the pool of authenticated users who can reach the endpoint (trade-off: administrative overhead and possible workflow disruption), and use a WAF or reverse-proxy rule to block requests to the affected plugin endpoints (trade-off: requires identifying the exact routes and may break legitimate plugin functionality). Review WordPress role capabilities so only trusted roles retain plugin-related permissions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CVE-2026-112222 is a CWE-862 Missing Authorization issue in the Surfer SEO WordPress plugin. The provided CPE, cpe:2.3:a:surfer:surfer:*:*:*:*:*:*:*:*, identifies the Surfer plugin as the affected component, with the advisory bounding affected versions through 1.8.0.744. The root cause is an incorrectly configured access-control check on plugin functionality: the code does not properly verify that the requesting user has the required capability or role before performing an action. The assessed vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N indicates the endpoint is reachable over the network and requires only a low-privileged authenticated account; successful exploitation yields low-impact confidentiality and integrity effects, with no scope change or availability impact. The provided data does not include public exploit code or a CISA KEV listing.
Know when Surfer gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Network-reachable plugin endpoint with low complexity and no user interaction, but a valid low-privileged account is required so PR:L; impact limited to low C and I with no availability effect.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Missing Authorization vulnerability in Surfer Surfer surferseo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Surfer: from n/a through 1.8.0.744.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-104324
GHSA-qh4g-vhpv-7389
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB