Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessUnknown attack entry point
-
ExploitTrigger uncharacterized vulnerability in py3-tornado
-
ImpactAchieve unconfirmed impact
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No exploitation conditions can be determined from available data. The CVE description contains only the package name and fix version - no mention of specific features, configurations, protocols, or deployment modes required for exploitation. CVSS vector is absent, so attack vector (network vs. local), complexity, and privilege requirements cannot be assessed. Authentication requirements are not confirmed from available data. Security teams should treat the conditions as unknown and apply the patch rather than attempt conditional risk exclusion. |
| Impact | Available risk signals are sparse and point toward low immediate priority. No CVSS score or vector is provided, making it impossible to assess attack vector, complexity, privileges required, or impact scope from structured metadata. EPSS is 0.03% at the 11th percentile, indicating very low predicted exploitation probability relative to the broader CVE population. There is no CISA KEV listing and no public exploit code identified. The sole reporting source is the Alpine Linux vendor, and the description contains no detail beyond the fix version. Given the combination of missing CVSS data, very low EPSS, and absence of any exploitation signal, this appears to be a low-urgency patch but should be applied as a matter of routine patching hygiene for Alpine-based deployments of py3-tornado. Risk cannot be formally quantified without a CVSS vector or vulnerability description. |
| Exploit ScenarioDerived | Because the vulnerability description provides no detail about the flaw class, attack vector, or required conditions, a realistic exploit scenario cannot be constructed from available data. No proof-of-concept code has been identified. Fabricating a scenario from the package name alone would be speculative and is not appropriate for a security decision-making context. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 27, 2026
py3-tornado (the Python Tornado web framework packaged for Alpine Linux) contains a vulnerability addressed in Alpine package version 6.5.4-r0. The nature of the flaw - including its impact class, affected component, and exploitability - is not disclosed in available intelligence. The only confirmed remediation signal is the Alpine Linux vendor advisory fixing the package at version 6.5.4-r0. EPSS exploitation probability is very low at 0.03% (11th percentile), and no active exploitation or public proof-of-concept has been identified at time of analysis.
RemediationAI
The primary fix is to upgrade the py3-tornado Alpine package to version 6.5.4-r0 or later using the Alpine package manager: 'apk upgrade py3-tornado'. This is the only confirmed remediation action from available data. No workarounds or compensating controls are documented because the vulnerability type is unknown - generic controls cannot be responsibly recommended without knowing the flaw class. For Alpine-based Docker images, rebuild using a base image that pulls py3-tornado >= 6.5.4-r0. No advisory URL beyond the Alpine Linux package repository was provided in the source data.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in pypi
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Tornado is a Python web framework and asynchronous networking library widely used for high-concurrency applications, WebSocket servers, and non-blocking I/O services. The Alpine Linux package py3-tornado bundles the upstream Tornado library for Alpine-based systems (including Docker containers and edge deployments). The Alpine package version 6.5.4-r0 corresponds to upstream Tornado 6.5.4. No CWE is assigned, so the root cause class - whether HTTP parsing flaw, memory mismanagement, logic error, or other - cannot be determined from available data. No CPE strings were provided to further scope affected configurations.
Know when Tornado gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Alpine Linux: py3-tornado fixed in 6.5.4-r0
Blast Radius
ecosystem impact- 1 pypi packages depend on tornado (1 direct, 0 indirect)
Ecosystem-wide dependent count for version 6.5.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
An issue in Docmosis Tornado v.2.9.7 and before allows a remote attacker to execute arbitrary code via a crafted script
An issue was discovered in Docmosis Tornado prior to version 2.9.5. Rated high severity (CVSS 8.8), this vulnerability i
py3-tornado in Alpine Linux received a security fix packaged as version 6.5.4-r0, addressing an unspecified vulnerabilit
Docmosis Tornado <= 2.9.4 is vulnerable to Directory Traversal leading to the disclosure of arbitrary content on the fil
An issue was discovered in Docmosis Tornado prior to version 2.9.5. Rated high severity (CVSS 7.5), this vulnerability i
Denial of service in the Tornado web framework's CurlAsyncHTTPClient (all releases before 6.5.9) lets an unauthenticated
In versions of Tornado prior to 6.5.5, the only limit on the number of parts in `multipart/form-data` is the `max_body_s
Memory amplification denial of service in the Tornado Python web framework before 6.5.8 lets unauthenticated remote atta
Credential leakage in Tornado's CurlAsyncHTTPClient (all releases through 6.5.6) lets sensitive per-request state — clie
Unauthenticated local file disclosure in Tornado before 6.5.9 lets remote attackers read files outside a configured stat
Denial-of-service in Tornado prior to 6.5.8 allows unauthenticated remote attackers to stall the entire server by sendin
Tornado Python web framework on Alpine Linux received a security fix in package version 6.5.4-r0, addressing an uncharac
EUVD-2025-203032
GHSA-pr2v-jx2c-wg9f
NVD
CVE.org
EPSS
Exploit-DB