Wordpress Plugin
CVE-2025-57931
MEDIUM
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V3 - Web Frontend Security Anti-CSRF tokens, SameSite cookies
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While CVSS scoring is unavailable, the vulnerability characteristics suggest moderate attack complexity: CSRF requires both victim interaction and prior authentication. The extremely low EPSS score (0.02%, percentile 4%) indicates negligible real-world exploitation likelihood despite the theoretical risk. No KEV confirmation or public exploit code availability was identified, further supporting low active threat status. SSVC framing shows exploitation is possible but not automated (requires social engineering to trick an admin into visiting a malicious page), and technical impact is limited to plugin configuration rather than remote code execution or data theft. This is a classic example of a valid vulnerability with significant real-world risk gap-patch it during normal maintenance cycles, but it does not warrant emergency response. |
| Exploit ScenarioDerived | An attacker creates a malicious webpage containing hidden HTML forms or JavaScript that targets the Ays Pro Popup box plugin's admin endpoints (e.g., to disable the plugin, modify popup content, or inject malicious code into popups). When a site administrator visits the attacker's page while logged into WordPress, the browser automatically includes the admin's session cookies, causing the unprotected admin action to execute without the administrator's knowledge. This could result in defaced popups, data harvesting, or lateral privilege escalation if the popup system is chained with other plugin vulnerabilities. No public exploit code or active exploitation in the wild has been confirmed, reducing practical risk. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 01, 2026
Cross-site request forgery in Ays Pro Popup box WordPress plugin versions up to 5.5.4 allows attackers to perform unauthorized actions (such as modifying plugin settings or creating popups) on behalf of authenticated administrators without their knowledge or consent. The vulnerability requires victim interaction (clicking a malicious link while logged in) but carries low exploitation probability (EPSS 0.02%, percentile 4%), suggesting limited real-world attack pressure despite the theoretical risk.
RemediationAI
Update Ays Pro Popup box to version 5.5.5 or later, which includes CSRF protections via proper nonce validation. Site administrators should navigate to the WordPress plugin dashboard, locate Ays Pro Popup box in the installed plugins list, and click 'Update' if available. If automatic updates are not enabled, download the latest version from the WordPress plugin repository and upload it manually. After patching, verify that popup management functions (creating, editing, deleting popups) require manual confirmation and are no longer susceptible to cross-origin requests. As a temporary mitigation for sites unable to patch immediately, restrict admin access via Web Application Firewall (WAF) rules or IP allowlisting, though this does not remediate the underlying vulnerability.
Affected ProductsAI
Ays Pro Popup box (WordPress plugin) versions from an unspecified baseline through 5.5.4 are affected. The exact earliest vulnerable version is not documented in available data. The plugin is identified by CPE data relating to WordPress plugins and is hosted on the WordPress plugin repository. Patch Stack database reference: https://patchstack.com/database/Wordpress/Plugin/ays-popup-box/vulnerability/wordpress-popup-box-plugin-5-5-4-cross-site-request-forgery-csrf-vulnerability
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This is a CSRF vulnerability (CWE-352) affecting the Ays Pro Popup box WordPress plugin, which handles popup creation and management. CSRF flaws occur when web applications fail to implement proper anti-forgery tokens (such as nonces in WordPress) in state-changing requests. The vulnerability indicates that sensitive plugin actions lack adequate CSRF protections, allowing an attacker to craft malicious HTML or JavaScript that, when visited by a logged-in administrator, will execute unwanted operations against the plugin without the user's explicit consent. WordPress uses nonce mechanisms to prevent CSRF; absence or improper validation of nonces in this plugin's admin handlers is the root cause.
Know when Wordpress Plugin gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Primary rating from Vendor (patchstack) · only source for this CVE.
CVSS VectorVendor: patchstack
Lifecycle Timeline
2DescriptionCVE.org
Cross-Site Request Forgery (CSRF) vulnerability in Ays Pro Popup box ays-popup-box allows Cross Site Request Forgery.This issue affects Popup box: from n/a through <= 5.5.4.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Request Forgery exploits the automatic credential inclusion behavior of web browsers.
More in Wordpress Plugin
View allThe Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
SQL injection in the NotificationX WordPress plugin (versions up to and including 2.8.2) allows unauthenticated remote a
The POST SMTP Mailer - Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress i
The MasterStudy LMS WordPress Plugin - for Online Courses and Education plugin for WordPress is vulnerable to union base
The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘hash’ parameter in
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB