Skip to main content

Mcphub CVE-2025-13822

| EUVDEUVD-2025-209433 MEDIUM
Authorization Bypass Through User-Controlled Key (CWE-639)
2026-04-14 CERT-PL GHSA-9vq7-9h42-j88h
5.3
CVSS 4.0 · Vendor: CERT-PL
View

Attack ChainAIDerived

Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain

  1. Access
    Gain network access to MCPHub segment
  2. Delivery
    Identify unprotected endpoints
  3. Exploit
    Craft request with target user identifier
  4. Execution
    Bypass authentication middleware
  5. Persist
    Execute action as impersonated user
  6. Impact
    Compromise target user's data or privileges

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
Impact

CVSS 5.3 reflects a medium-severity issue with low confidentiality and integrity impact (VC:L/VI:L) but no availability impact. The attack vector is Adjacent Network (AV:A), meaning the attacker must be on the same network segment, which significantly constrains real-world exploitability compared to network-wide attacks. The CVSS vector shows no complexity (AC:L), no user interaction required (UI:N), and no special privileges needed (PR:N), making exploitation straightforward once network access is gained. However, the constraint to AV:A (internal networks, VPN, etc.) rather than AV:N (internet-wide) substantially reduces the threat surface for most organizations. The integrity impact allows attackers to modify data as other users, which could enable fraud, privilege escalation, or lateral movement within trusted network boundaries. This is a real but localized risk-primarily concerning for organizations where physical or VPN access is possible and where internal threat models account for compromised network nodes.

Exploit ScenarioDerived

An attacker with access to the same network segment as a MCPHub instance (e.g., via VPN compromise, rogue wireless AP, or internal lateral movement) sends HTTP requests directly to unprotected endpoints, crafting the requests to include headers or identifiers that associate them with a legitimate user's session. Since the endpoints lack authentication middleware, the requests are processed as if they originated from that user, allowing the attacker to read sensitive data or modify records under the victim's identity without ever providing valid credentials.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Apr 14, 2026

MCPHub below version 0.11.0 allows unauthenticated attackers to bypass authentication on unprotected endpoints and perform actions with the privileges of other users. The vulnerability stems from missing authentication middleware on certain endpoints, enabling attackers on the local network (AV:A) to impersonate legitimate users without requiring credentials. No public exploit code or active exploitation has been confirmed at this time.

RemediationAI

Upgrade MCPHub to version 0.11.0 or later, which includes fixes to ensure all endpoints are protected by authentication middleware. Users unable to upgrade immediately should implement network-level access controls to restrict connections to MCPHub endpoints to trusted internal networks only, combined with monitoring for unusual endpoint access patterns. The patch in version 0.11.0 adds comprehensive authentication guards across all previously unprotected endpoints. For additional details, consult the CERT-PL advisory at https://cert.pl/en/posts/2026/04/CVE-2025-13822.

Affected VersionsENISA

MCPHub 0 <0.11.0

Affected Packages

npm @samanhappy/mcphub fix: 0.11.0
euvd mcphub fix: 0.11.0

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 2 packages in npm, euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

MCPHub is a model control plane hub application that manages API endpoints and user privileges. The vulnerability arises from incomplete implementation of authentication middleware across the application's endpoint layer, classified as CWE-639 (Authorization Bypass Through User-Controlled Key). The affected versions (all 0.x releases prior to 0.11.0) fail to enforce authentication checks on certain endpoints, allowing an attacker on the same network segment to issue requests that are processed with the context and permissions of existing users. This is a classic authorization enforcement gap where some API routes were not wrapped with the necessary authentication guard.

Know when Mcphub gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Vendor (CERT-PL) PRIMARY 5.3 MEDIUM
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Primary rating from Vendor (CERT-PL) · only source for this CVE.

CVSS VectorVendor: CERT-PL

Attack Vector
Adjacent
Attack Complexity
Low
Attack Requirements
None
Privileges Required
None
User Interaction
None
Vulnerable system: Confidentiality
Low
Vulnerable system: Integrity
Low
Vulnerable system: Availability
None
Subsequent system: Confidentiality
None
Subsequent system: Integrity
None
Subsequent system: Availability
None

Lifecycle Timeline

2
Patch released
Apr 15, 2026 - 20:30 nvd
Patch available
CVE Published
Apr 14, 2026 - 10:23 nvd
MEDIUM 5.3

DescriptionCVE.org

MCPHub in versions below 0.11.0 is vulnerable to authentication bypass. Some endpoints are not protected by authentication middleware, allowing an unauthenticated attacker to perform actions in the name of other users and using their privileges.

Threat Intelligence Overview

EPSS Score
0.0%
Top 87% exploitable
Data Quality
7 sources
Confidence: High
EUVD NVD CVE.org EPSS Vulnrichment GitHub VulDB

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation
None
System Exposure· derived
Controlled
Automatable
No
Human Impact· derived
Medium
Technical Impact
Partial

Priority Score

26
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +26
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy