Wp Maps Store Locator Google Maps Openstreetmap Mapbox Listing Directory Filters
CVE-2025-13364
|
EUVD-2025-209491
MEDIUM
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconAcquire contributor account
-
DeliveryNavigate to page editor
-
ExploitInsert malicious shortcode
-
InstallPublish/save page
-
C2Payload stored in database
-
ExecutePage loaded by visitor
-
ImpactMalicious script executes in visitor browser
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress account with contributor-level access or above (PR:L in CVSS vector). Attackers must have the ability to edit or create pages/posts and use the 'put_wpgm' shortcode. The vulnerability is NOT limited to default configurations - any WordPress site with the WP Maps plugin installed version 4.8.7 or earlier is vulnerable if any contributor or higher-privileged user account exists. The shortcode handler itself must be invoked (i.e., the page containing the malicious shortcode must be accessed), but this occurs automatically when the page is viewed, meaning no special user interaction or privileged configuration is needed to trigger the stored payload once it is planted. The vulnerability does NOT require the victim to click a link, disable security features, or interact with the malicious content; the JavaScript executes unconditionally when the page loads. Limiting factors: (1) Requires valid WordPress contributor account or compromised account at that privilege level, (2) Requires ability to publish or edit page/post content, (3) Only affects installations with the WP Maps plugin active version 4.8.7 or earlier. |
| Impact | This vulnerability presents moderate-to-high real-world risk despite a CVSS score of 6.4 (medium). Key risk signals: (1) Stored XSS is more dangerous than reflected XSS because the malicious payload persists in the database and fires for all visitors without requiring a phishing link, (2) Authentication is required (PR:L) but contributor-level access is commonly granted to multiple WordPress users, increasing the threat surface, (3) CVSS scope change (S:C) indicates impact extends beyond the attacker's privileges - all site visitors are vulnerable, (4) No special complexity (AC:L) means exploitation is trivial once a contributor account is compromised or misused, (5) Patch exists (version 4.8.8), reducing complexity for defenders but many WordPress installations lag in plugin updates. The CVSS score of 6.4 underrepresents real-world severity because it reflects the authentication requirement; however, in environments with multiple contributors or where contributor accounts are compromised, this becomes a critical integrity and confidentiality risk. Attack conditions are minimal: an attacker simply embeds a script in the shortcode attribute (e.g., |
| Exploit ScenarioDerived | A disgruntled contributor with WordPress contributor-level access uses the WP Maps shortcode to inject a keylogger or credential-harvesting script into a high-traffic page (e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 16, 2026
Stored XSS in WP Maps plugin for WordPress allows authenticated contributors to inject malicious scripts via the 'put_wpgm' shortcode due to insufficient input sanitization and output escaping. Attackers with contributor-level access and above can craft malicious shortcode attributes that persist in page content and execute for all subsequent visitors. All versions up to 4.8.7 are affected; patched version 4.8.8 is available.
RemediationAI
Immediately upgrade the WP Maps plugin to version 4.8.8 or later, which patches the input sanitization and output escaping flaws in the 'put_wpgm' shortcode handler. Update via WordPress Admin Dashboard (Plugins > Installed Plugins > WP Maps > Update) or download from https://plugins.trac.wordpress.org/changeset?old_path=wp-google-map-plugin/tags/4.8.7/wp-google-map-plugin.php&new_path=wp-google-map-plugin/tags/4.8.8/wp-google-map-plugin.php. While waiting for the update, audit all published pages and posts containing the 'put_wpgm' shortcode to ensure no malicious attributes are present; use WordPress Search & Replace plugins if needed to quickly identify affected content. Restrict contributor-level access to only trusted users and consider temporarily revoking the ability to edit pages/posts containing this shortcode until the patch is deployed. Monitor site traffic and log files for evidence of XSS payload injection or execution (search for unusual script tags or event handlers in page content). These workarounds have limited effectiveness and are not substitutes for patching; the primary mitigation is upgrading to 4.8.8 immediately.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the WP Maps - Store Locator plugin's handling of the 'put_wpgm' shortcode, a WordPress feature that allows administrators and contributors to embed dynamic content via square-bracket syntax. The plugin fails to properly sanitize user-supplied shortcode attributes before storing them in the database and fails to escape the output when rendering the shortcode on the front-end. This violates WordPress security best practices for both sanitization (cleaning input at entry) and escaping (cleaning output at display). CWE-79 (Improper Neutralization of Input During Web Page Generation) is the root cause; the plugin does not filter or validate attribute values that could contain HTML/JavaScript payloads. The attack vector is network-based because WordPress shortcodes are processed server-side but the injection occurs through the web interface, and authentication is required (PR:L, contributor level minimum). The scope is changed (S:C) because stored XSS affects all site visitors, not just the attacker.
Know when Wp Maps Store Locator Google Maps Openstreetmap Mapbox Listing Directory Filters gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary rating from Vendor (Wordfence) · only source for this CVE.
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The WP Maps - Store Locator,Google Maps,OpenStreetMap,Mapbox,Listing,Directory & Filters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'put_wpgm' shortcode in all versions up to, and including, 4.8.7. This is due to insufficient input sanitization and output escaping on user-supplied shortcode attributes. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
GHSA-9726-56v6-8wh4
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB