Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V15 - Secure Coding and Architecture Variable initialization
|
| Impact | The CVSS 3.1 score of 6.5 (AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N) correctly reflects a medium-to-high risk: local attack vector with low complexity, low privilege requirement, no user interaction needed, and high confidentiality impact across system boundaries. However, this is a pure information disclosure with no integrity or availability impact. Real-world exploitation probability depends on EPSS data (not provided in intelligence), but CWE-908 vulnerabilities typically have moderate-to-high automatable exploit potential once local code execution is achieved. The vulnerability is NOT listed in CISA KEV, suggesting no active in-the-wild exploitation campaigns are currently tracked. The absence of a public proof-of-concept in references limits immediate threat, but the technical simplicity of memory-reading attacks means exploit development is trivial once details are disclosed. Priority should be HIGH for systems processing sensitive data or in multi-tenant environments, but MEDIUM for isolated single-user deployments. This is a legitimate priority issue—not an inflated CVSS score—due to the reliability and automation potential of the attack. |
| Exploit ScenarioDerived | An attacker with local shell access (compromised user account or application vulnerability) executes code that reads uninitialized heap or stack memory regions allocated to other processes or kernel subsystems. By repeatedly triggering allocations or scanning memory, the attacker retrieves case-sensitive secrets such as session tokens, cryptographic material, or user credentials that were not properly cleared during prior deallocations. This requires local code execution but only standard user-level privileges and no user interaction—a realistic scenario in shared mobile devices, IoT systems running OpenHarmony, or cloud VMs where containerization or privilege isolation is incomplete. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 16, 2026
OpenHarmony versions 5.0.3 and earlier contain an information disclosure vulnerability caused by use of uninitialized resources, allowing local attackers to leak sensitive case-sensitive data. The vulnerability affects OpenHarmony deployments across all product lines up to v5.0.3.x (per EUVD-2025-208673). An attacker with local access and standard user privileges can read uninitialized memory regions to obtain confidential information without requiring user interaction, though there is no indication of active exploitation in public KEV databases at this time.
RemediationAI
Upgrade OpenHarmony to version 5.0.4 or later once released by the vendor; check the official OpenHarmony security advisory at https://gitcode.com/openharmony/security/tree/master/zh/security-disclosure/2025/2025-12.md for patch availability and timeline. Until patches can be deployed, implement local access controls by restricting shell access and application execution privileges using OpenHarmony's Discretionary Access Control (DAC) or mandatory access control mechanisms, disable inter-process memory sharing where possible, and enforce strong authentication for local system access. For sensitive deployments, consider network isolation of affected systems until patches are confirmed and tested in your environment.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is rooted in CWE-908 (Use of Uninitialized Resource), a memory safety issue where uninitialized variables or heap/stack regions retain sensitive data from prior allocations. In the OpenHarmony operating system (as confirmed by CPE cpe:2.3:a:openharmony:openharmony:*:*:*:*:*:*:*:*), resource initialization routines fail to properly zero or sanitize memory before allocation to user-space processes. This allows local processes to read residual data containing case-sensitive information such as encryption keys, authentication tokens, or other secrets that were previously stored in that memory. The attack requires local code execution capability but no special privileges beyond standard user-level access, making it a practical concern in multi-tenant or shared-device scenarios.
Know when Openharmony gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
in OpenHarmony v5.0.3 and prior versions allow a local attacker case sensitive information leak through use of uninitialized resource.
Executive ViewAI
Organizations using OpenHarmony should be aware of notable risk from CVE-2025-12736 rated CVSS 6.5. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Related Vulnerabilities in OpenHarmony Local Privilege Escalation
View all 4More in Openharmony
View allin OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
Arbitrary code execution in OpenHarmony v6.0 and earlier enables remote attackers with low privileges to execute code wi
in OpenHarmony v4.1.2 and prior versions allow a local attacker cause the common permission is upgraded to root and sens
in OpenHarmony v3.2.4 and prior versions allow a local attacker arbitrary code execution in any apps through improper in
in OpenHarmony v3.2.4 and prior versions allow a local attacker arbitrary code execution in any apps through use after f
in OpenHarmony v4.0.0 and prior versions allow an adjacent attacker arbitrary code execution in any apps through use aft
OpenHarmony-v3.1.2 and prior versions have an authenication bypass vulnerability in a callback handler function of Softb
OpenHarmony-v3.1.1 and prior versions have a permission bypass vulnerability. Rated high severity (CVSS 8.8), this vulne
EUVD-2025-208673
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB