Skip to main content

Zenml CVE-2024-2213

LOW
Unverified Password Change (CWE-620)
2024-06-06 security@huntr.dev
3.3
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A07:2025 - Authentication Failures
ASVS 5.0
V6 - Authentication Password change verification
Impact

CVSS score of 3.3 (LOW). Attack characteristics: local attack vector, low complexity, low privileges required, no user interaction not required. Public proof-of-concept exploit code is available.

Exploit ScenarioDerived

Successful exploitation could compromise the low-severity affected system.

Monitor Track and reassess. Why: LOW severity (CVSS 0.1-3.9).
Patch available 0.2% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAI

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Rated low severity (CVSS 3.3), this vulnerability is low attack complexity. Public exploit code available.

RemediationAI

A vendor patch is available. Apply the latest security update as soon as possible. Apply vendor patches when available. Implement network segmentation and monitoring as interim mitigations.

Affected Packages

pypi zenml fix: 0.56.3

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in pypi

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified under CWE-620. An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3. Affected products include: Zenml. Version information: version 0.56.3..

Know when Zenml gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 3.3 LOW
AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Local
Attack Complexity
Low
Privileges Required
Low
User Interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
Low
Availability
None

DescriptionNVD

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Threat Intelligence Overview

EPSS Score
0.2%
Top 85% exploitable
Exploit
POC
Public exploit code exists
Data Quality
3 sources
Confidence: Low

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity LOW
CISA KEV No
Public POC Yes
EPSS 0.2%
Patch available Yes
Active threat No
Deciding rule
LOW severity (CVSS 0.1-3.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Defer
Exploitation· derived
Poc
System Exposure· derived
Small
Automatable· derived
No
Human Impact· derived
Low

Priority Score

36
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +16
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.

Affected Products (CPE)NVD

cpe:2.3:a:zenml:zenml:*:*:*:*:*:*:*:*

More in Zenml

View all
CVE-2024-2083 CRITICAL POC
9.9 Apr 16

A directory traversal vulnerability exists in the zenml-io/zenml repository, specifically within the /api/v1/steps endpo

CVE-2024-4680 HIGH POC
8.8 Jun 08

A vulnerability in zenml-io/zenml version 0.56.3 allows attackers to reuse old session credentials or session IDs due to

CVE-2024-25723 HIGH POC
8.8 Feb 27

ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because t

CVE-2025-8406 HIGH POC
7.8 Oct 05

ZenML 0.83.1 can be induced to write files outside the intended extraction directory when PathMaterializer.load processe

CVE-2024-2035 MEDIUM POC
6.5 Jun 06

An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1

CVE-2024-5062 MEDIUM POC
6.1 Jun 30

A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1. Rated medium sever

CVE-2024-2383 MEDIUM POC
6.1 Jun 06

A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application's failu

CVE-2024-4311 MEDIUM POC
5.4 Nov 14

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password chan

CVE-2024-2171 MEDIUM POC
4.8 Jun 06

A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within t

CVE-2024-28424 HIGH
8.8 Mar 14

zenml v0.55.4 was discovered to contain an arbitrary file upload vulnerability in the load function at /materializers/cl

CVE-2026-68772 HIGH
8.5 Aug 07

Remote code execution in ZenML 0.94.6 allows any attacker with write access to a shared artifact store to plant a malici

CVE-2024-2260 MEDIUM POC
4.2 Apr 16

A session fixation vulnerability exists in the zenml-io/zenml application, where JWT tokens used for user authentication

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy