Skip to main content

Spark CVE-2023-22946

CRITICAL
Improper Privilege Management (CWE-269)
2023-04-17 security@apache.org
9.9
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Least privilege enforcement
MITRE ATT&CK

1 technique across 1 tactic: Privilege Escalation

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

CVSS score of 9.9 (CRITICAL). Attack characteristics: network attack vector, low complexity, low privileges required, no user interaction not required.

Exploit ScenarioDerived

A remote attacker could escalate privileges to gain unauthorized elevated access by sending crafted requests to the affected application.

Act Now Prioritize within 24-48h. Why: CRITICAL severity.
Patch available 1.1% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAI

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. Rated critical severity (CVSS 9.9), this vulnerability is remotely exploitable, low attack complexity. No vendor patch available.

RemediationAI

No vendor patch is available at time of analysis. Monitor vendor advisories for updates. Apply principle of least privilege, validate privilege transitions, implement proper role separation.

Affected Packages

maven org.apache.spark:spark-core_2.12 fix: 3.3.3
maven org.apache.spark:spark-core_2.13 fix: 3.3.3
maven pyspark fix: 3.3.2
pypi org-apache-spark:spark-core-2-12 fix: 3.3.3
pypi org-apache-spark:spark-core-2-13 fix: 3.3.3
pypi pyspark fix: 3.3.2, 3.4.0

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 5 packages in maven, pypi

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified as Improper Privilege Management (CWE-269), which allows attackers to escalate privileges to gain unauthorized elevated access. In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications. Affected products include: Apache Spark. Version information: prior to 3.4.0.

Know when Spark gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 9.9 CRITICAL
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High

DescriptionNVD

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.

Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

Threat Intelligence Overview

EPSS Score
1.1%
Top 38% exploitable
Data Quality
2 sources
Confidence: Low

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity CRITICAL
CISA KEV No
Public POC No
EPSS 1.1%
Patch available Yes
Active threat No
Deciding rule
CRITICAL severity
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact· derived
Medium

Priority Score

51
Low Medium High Critical
KEV: 0
EPSS: +1
CVSS: +50
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.

Affected Products (CPE)NVD

cpe:2.3:a:apache:spark:*:*:*:*:*:*:*:*

More in Spark

View all
CVE-2022-33891 HIGH POC
8.8 Jul 18

The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. Rated high sev

CVE-2020-9480 CRITICAL POC
9.8 Jun 23

In Apache Spark 2.4.5 and earlier, a standalone resource manager's master may be configured to require authentication (s

CVE-2020-12772 HIGH POC
8.8 May 12

An issue was discovered in Ignite Realtime Spark 2.8.3 (and the ROAR plugin for it) on Windows. Rated high severity (CVS

CVE-2016-9177 HIGH POC
7.5 Nov 04

Directory traversal vulnerability in Spark 2.5 allows remote attackers to read arbitrary files via a .. Rated high sever

CVE-2018-11770 MEDIUM POC
4.2 Aug 13

From version 1.3.0 onward, Apache Spark's standalone master exposes a REST API for job submission, in addition to the su

CVE-2024-23945 MEDIUM POC
5.9 Dec 23

Signing cookies is an application security feature that adds a digital signature to cookie data to verify its authentici

CVE-2018-17190 CRITICAL
9.8 Nov 19

In all versions of Apache Spark, its standalone resource manager accepts code to execute on a 'master' host, that then r

CVE-2018-8024 MEDIUM POC
5.4 Jul 12

In Apache Spark 2.1.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, it's possible for a malicious user to construct a URL pointin

CVE-2023-32007 HIGH
8.8 May 02

** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option s

CVE-2017-12612 HIGH
7.8 Sep 13

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. Rate

CVE-2016-1322 HIGH
7.5 Feb 12

The REST interface in Cisco Spark 2015-07-04 allows remote attackers to bypass intended access restrictions and create a

CVE-2019-10172 HIGH
7.5 Nov 18

A flaw was found in org.codehaus.jackson:jackson-mapper-asl:1.9.x libraries. Rated high severity (CVSS 7.5), this vulner

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy